Bug 50700 - unable to mount nfs exported file systems form Solaris 2.7 machine
unable to mount nfs exported file systems form Solaris 2.7 machine
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 08:00 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 10:40:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-02 08:00:30 EDT
Description of Problem:I am unable to mount nfs exported file systems from
a Solaris 2.7 machine. Also if I run rpm with the -q option on net-utils I
am told the package is not installed (same if I try to uninstall the
package). If, however I try to install the package using the -ivh option I
am told it is installed. Gnome rpm crashes with a segmentation fault if I
find the package and try to query it or uninstall it. I am running Linux on
a laptop with a pcmcia network card (D-Link DFE650).


How Reproducible:Either run command mount /mnt/home at the command line
(the file system is set as user mountable), use the desktop icon to mount
the file system, or attempt to mount the file system using linuxconf, or
attempt to mount the file system at boot time.


Steps to Reproduce:
1. Always reproducable
2. 
3. 

Actual Results:If  I run mount /mnt/home from the command line, or use the
desktop icon, I get the error mount: RPC: Timed out, using linuxconf I get
the error  "* The command takes more than 15 seconds to execute, odd" and
the option to kill the command, and if I try to mount at boot time I get
the error Network unreachable (but I can access the network using nslookup,
ping etc after booting and lpd successfully accesses network printers).


Expected Results:File system mounted and accessable


Additional Information:Extract from netconf.log attached
Comment 1 Bob Matthews 2001-08-02 10:40:18 EDT
These are really two separate bugs.  You'll probably get better answers in the
future if you file two bug reports.

Now, having said that...

> If, however I try to install the package using the -ivh option I
> am told it is installed.

Try passing the -U option to rpm.  If that doesn't work, try rebuilding the rpm
database.

> I run mount /mnt/home from the command line, or use the
> desktop icon, I get the error mount: RPC: Timed out

This usually means that the server is not responding to mount requests.  Either
the server is unreachable from the client, the server doesn't recognize the
client, or the server/client is misconfigured.

Since you can ping the server, I would reject the first option out-of-hand. 
Recheck the server's /etc/exports, and make sure all the required services
(statd, mountd, portmapper, etc.) are running on the server.  The portmapper and
statd should also be running on the client.

If all this is correct, see if you can telnet into the nfs port on the server.

Do you have another non-linux machine you can use as a test client?  If you can
mount from that machine, that would narrow it down to a linux-specific problem.

As a final option, you might try exporting the file system as NFS-version2. 
Make sure you are exporting using UDP (which is the Solaris default, I believe)
and not TCP.
Comment 2 Bob Matthews 2001-08-06 11:05:09 EDT
> I have managed to figure out what the problem is - I changed the
> firewall security option to high instead of the default medium. This
> has caused too much to be dis-allowed in terms of udp traffic over the
> network. I have added the following line to the ipchains start up
> script /etc/sysconfig/ipchains
> -A input -s 128.240.151.0/24 -p udp -i eth0 -j ACCEPT
> which allows udp traffic with the local machines and I can now mount
> the file systems.


Note You need to log in before you can comment on or make changes to this bug.