Bug 507005 - issues with nozomi mobile broadband pcmcia card
issues with nozomi mobile broadband pcmcia card
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 14:40 EDT by Graham Biswell
Modified: 2014-08-14 21:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.6.29.6-213.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 17:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Biswell 2009-06-19 14:40:53 EDT
Description of problem:
Nozomi mobile broadband pcmcia card doesn't work with F11. Attempts by NetworkManager or wvdial etc to use the device as a modem result in kernel traces & in one case eventual lockup of laptop.

Version-Release number of selected component (if applicable):
kernel-2.6.29.4-167.fc11.x86_64 & kernel-2.6.29.5-191.fc11.x86_64 both exhibit problem.

How reproducible:
Every time.

Steps to Reproduce:
1. Insert card. dmesg shows the following as usual:
pcmcia_socket pcmcia_socket0: pccard: CardBus card inserted into slot 0
pci 0000:16:00.0: reg 10 32bit mmio: [0x000000-0x0007ff]
Initializing Nozomi driver 2.1d (build date: Jun 16 2009 23:25:00)
nozomi 0000:16:00.0: Init, new card found
nozomi 0000:16:00.0: enabling device (0000 -> 0002)
nozomi 0000:16:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
nozomi 0000:16:00.0: Card type is: 2048
nozomi 0000:16:00.0: Version of card: 3
nozomi 0000:16:00.0: Initialization OK!
nozomi 0000:16:00.0: Device READY!

2. Try to use the device with wvdial. wvdial starts ppp which fails to connect & eventually times out. dmesg shows the following ...

BUG: sleeping function called from invalid context at kernel/mutex.c:88
in_atomic(): 1, irqs_disabled(): 0, pid: 0, name: swapper
Pid: 0, comm: swapper Not tainted 2.6.29.5-191.fc11.x86_64 #1
Call Trace:
 <IRQ>  [<ffffffff8103fd8f>] __might_sleep+0x10b/0x110
 [<ffffffff813aaa0e>] mutex_lock+0x22/0x38
 [<ffffffff8122d408>] echo_set_canon_col+0x1e/0x45
 [<ffffffff8122eab5>] n_tty_receive_buf+0x2fb/0xe50
 [<ffffffff81229f3c>] ? tty_kref_put+0x1e/0x20
 [<ffffffff81231e65>] ? tty_port_tty_get+0x42/0x4d
 [<ffffffff81029f7f>] ? default_spin_lock_flags+0x9/0xe
 [<ffffffff81230708>] ? tty_ldisc_try+0x3c/0x44
 [<ffffffff81231441>] flush_to_ldisc+0x10c/0x19f
 [<ffffffff81231524>] tty_flip_buffer_push+0x50/0x61
 [<ffffffffa03d0a7f>] interrupt_handler+0xc8b/0xcc4 [nozomi]
 [<ffffffff8103a98a>] ? __enqueue_entity+0x7b/0x7d
 [<ffffffff8103cd30>] ? enqueue_entity+0x1af/0x1b8
 [<ffffffff8103cd63>] ? enqueue_task_fair+0x2a/0x6d
 [<ffffffff810389d7>] ? resched_task+0x33/0x75
 [<ffffffff813abe44>] ? _spin_unlock_irqrestore+0x2c/0x42
 [<ffffffff81062e08>] ? clocksource_read+0xc/0xe
 [<ffffffff81063094>] ? getnstimeofday+0x5f/0xb3
 [<ffffffff813abbfa>] ? _spin_lock+0xe/0x11
 [<ffffffff81015942>] ? update_vsyscall+0xd6/0xf0
 [<ffffffffa0055975>] ? radeon_driver_irq_handler+0x2f/0xea [radeon]
 [<ffffffff8108befb>] handle_IRQ_event+0x38/0x74
 [<ffffffff8108d8a5>] handle_fasteoi_irq+0x91/0xde
 [<ffffffff81013ba4>] do_IRQ+0xd9/0x151
 [<ffffffff81011e93>] ret_from_intr+0x0/0x2e
 <EOI>  [<ffffffff81216404>] ? acpi_idle_enter_bm+0x28f/0x2de
 [<ffffffff812163fc>] ? acpi_idle_enter_bm+0x287/0x2de
 [<ffffffff812ec70f>] ? cpuidle_idle_call+0x8d/0xc2
 [<ffffffff810102a1>] ? cpu_idle+0x68/0xb3
 [<ffffffff813a5e3c>] ? start_secondary+0x199/0x19e
BUG: scheduling while atomic: swapper/0/0x10010000

Followed by a few of these ...

BUG: scheduling while atomic: swapper/0/0x10010000
Modules linked in: nozomi fuse nfs lockd nfs_acl auth_rpcgss ipt_MASQUERADE iptable_nat nf_nat bridge stp llc bnep sco l2cap bluetooth sunrpc ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput snd_hda_codec_analog arc4 ecb thinkpad_acpi hwmon snd_hda_intel snd_hda_codec iwl3945 snd_hwdep snd_pcm joydev pcspkr e1000e yenta_socket snd_timer i2c_i801 rsrc_nonstatic snd iTCO_wdt iTCO_vendor_support video soundcore output mac80211 snd_page_alloc lib80211 cfg80211 sha256_generic cbc aes_x86_64 aes_generic dm_crypt radeon drm i2c_algo_bit i2c_core [last unloaded: microcode]
CPU 1:
Modules linked in: nozomi fuse nfs lockd nfs_acl auth_rpcgss ipt_MASQUERADE iptable_nat nf_nat bridge stp llc bnep sco l2cap bluetooth sunrpc ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput snd_hda_codec_analog arc4 ecb thinkpad_acpi hwmon snd_hda_intel snd_hda_codec iwl3945 snd_hwdep snd_pcm joydev pcspkr e1000e yenta_socket snd_timer i2c_i801 rsrc_nonstatic snd iTCO_wdt iTCO_vendor_support video soundcore output mac80211 snd_page_alloc lib80211 cfg80211 sha256_generic cbc aes_x86_64 aes_generic dm_crypt radeon drm i2c_algo_bit i2c_core [last unloaded: microcode]
Pid: 0, comm: swapper Not tainted 2.6.29.5-191.fc11.x86_64 #1 2007A16
RIP: 0010:[<ffffffff81216404>]  [<ffffffff81216404>] acpi_idle_enter_bm+0x28f/0x2de
RSP: 0018:ffff8800be917ea8  EFLAGS: 00000246
RAX: ffffffff8177e290 RBX: ffff8800be917ee8 RCX: ffff8800be917e78
RDX: ffff88007f8b3000 RSI: 00000039da31b1cf RDI: ffff880001035d00
RBP: ffffffff81011e8e R08: 0000000000000000 R09: 0000000000000246
R10: ffff8800be911018 R11: ffff8800b40951e0 R12: 0000000000036066
R13: ffff8800be917e48 R14: ffffffff81063094 R15: ffff8800be917e18
FS:  0000000000000000(0000) GS:ffff8800be8ed180(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 00007f7e9fa217dd CR3: 0000000000201000 CR4: 00000000000026e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Call Trace:
 [<ffffffff812163fc>] ? acpi_idle_enter_bm+0x287/0x2de
 [<ffffffff812ec70f>] ? cpuidle_idle_call+0x8d/0xc2
 [<ffffffff810102a1>] ? cpu_idle+0x68/0xb3
 [<ffffffff813a5e3c>] ? start_secondary+0x199/0x19e


Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2009-06-20 05:21:08 EDT
Fixed in kernel-2.6.29.5-195
Comment 2 Fedora Update System 2009-07-08 08:14:33 EDT
kernel-2.6.29.6-213.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.29.6-213.fc11
Comment 3 Fedora Update System 2009-07-16 03:13:28 EDT
kernel-2.6.29.6-213.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7617
Comment 4 Fedora Update System 2009-07-22 17:58:08 EDT
kernel-2.6.29.6-213.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 mkpyc9 2009-09-09 05:06:31 EDT
The nozomi module still seems to be broken in the 2.6.30 kernel. Attempting to connect via NetworkManager and using system-config-network dialup both fail using the nozomi.ko supplied with the kernel (as indeed they did for kernel 2.6.29). However, both methods work when using a re-compiled nozomi source from the 2.6.28 kernel.

Note You need to log in before you can comment on or make changes to this bug.