Bug 507073 - virt-manager hangs while setting up WinXP VM ....
virt-manager hangs while setting up WinXP VM ....
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 10:28 EDT by William A. Mahaffey III
Modified: 2009-08-07 10:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 516282 (view as bug list)
Environment:
Last Closed: 2009-08-07 08:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager log .... (42.76 KB, text/plain)
2009-06-22 15:15 EDT, William A. Mahaffey III
no flags Details
guest.log.gz .... (465 bytes, application/x-gzip)
2009-06-22 15:19 EDT, William A. Mahaffey III
no flags Details
new virt-manager.log file .... (67.29 KB, text/plain)
2009-06-23 13:06 EDT, William A. Mahaffey III
no flags Details
virt-manager.log from this A.M., consistent w/ last post about WinXP guest log .... (91.66 KB, text/plain)
2009-06-24 10:00 EDT, William A. Mahaffey III
no flags Details
screen shot of virt-manager at the moment of death .... (120.55 KB, image/png)
2009-07-03 16:39 EDT, William A. Mahaffey III
no flags Details

  None (edit)
Description William A. Mahaffey III 2009-06-20 10:28:05 EDT
Description of problem:I am trying to use virt-manager to set up a WinXP-SP2 qemu-kvm VM. I get to step 5 when it tries to go ahead & setup the VM & the process hangs (went for ~12 hrs. last night, I am trying again this A.M.).


Version-Release number of selected component (if applicable):latest as of this A.M.


How reproducible: try it yourself


Steps to Reproduce:
1.invoke virt-manager from a bash CLI
2.enter data for VM (I took almost all defaults)
3.hit finish button, last progress dialog opens up, DVD-drive flashes for about 10 sec., then everything hangs ....
  
Actual results:process hangs


Expected results:creates new VM


Additional info: from my messages file this A.M.:



Jun 20 09:16:08 athloncube gnome-keyring-daemon[2124]: adding removable location: volume_label_WXPVOL_EN at /media/WXPVOL_EN
Jun 20 09:16:08 athloncube libvirtd: 09:16:08.625: error : Domain not found
Jun 20 09:16:28 athloncube libvirtd: 09:16:28.081: error : Domain not found
Jun 20 09:16:56 athloncube libvirtd: 09:16:56.751: error : Domain not found
Jun 20 09:16:56 athloncube libvirtd: 09:16:56.770: error : Domain not found
Jun 20 09:17:10 athloncube libvirtd: 09:17:10.063: error : Domain not found
Jun 20 09:17:10 athloncube libvirtd: 09:17:10.082: error : Domain not found
Jun 20 09:17:10 athloncube libvirtd: 09:17:10.276: error : Domain not found
Jun 20 09:17:10 athloncube libvirtd: 09:17:10.326: error : Domain not found
Jun 20 09:17:10 athloncube kernel: device vnet0 entered promiscuous mode
Jun 20 09:17:10 athloncube kernel: virbr0: topology change detected, propagating
Jun 20 09:17:10 athloncube kernel: virbr0: port 1(vnet0) entering forwarding state
Jun 20 09:17:10 athloncube NetworkManager: nm_device_ethernet_new: assertion `driver != NULL' failed
Jun 20 09:17:14 athloncube ntpd[1652]: Listening on interface #10 vnet0, fe80::85b:e2ff:fe83:2015#123 Enabled
Jun 20 09:17:15 athloncube nm-system-settings: Added default wired connection 'Auto vnet0' for /org/freedesktop/Hal/devices/net_0a_5b_e2_83_20_15


from ps in another window:


[wam@athloncube, ~, 9:20:48am] 66 % ps -elf | grep virt
5 S root      1873     1  0  80   0 - 116360 poll_s Jun19 ?       00:00:04 libvirtd --daemon
5 S root     24080     1  0  80   0 - 620530 poll_s 09:14 ?       00:00:03 python /usr/share/virt-manager/virt-manager.py
0 S root     24131     1  0  80   0 - 183132 poll_s 09:17 ?       00:00:02 /usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name WinXP -uuid e7929660-ca3f-ae92-5913-0356ea556392 -monitor pty -pidfile /var/run/libvirt/qemu//WinXP.pid -localtime -no-reboot -no-acpi -boot d -drive file=/home/VMs/hda.img,if=ide,index=0 -drive file=/dev/sr0,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:4f:c3:31,vlan=0 -net tap,fd=18,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0
0 S wam      24339  2397  0  80   0 -  1554 pipe_w 09:27 pts/0    00:00:00 grep virt
[wam@athloncube, ~, 9:27:10am] 66 %
Comment 1 Mark McLoughlin 2009-06-22 12:31:43 EDT
See https://fedoraproject.org/wiki/Reporting virtualization bugs

What versions of virt-manager, python-virtinst libvirt and qemu-system-x86? Please attach ~/.virt-manager/virt-manager.log and /var/log/libvirt/qemu/$guest.log

FWIW, installing WinXP SP2 works fine for me on F-11
Comment 2 William A. Mahaffey III 2009-06-22 15:15:01 EDT
Created attachment 348976 [details]
virt-manager log ....
Comment 3 William A. Mahaffey III 2009-06-22 15:19:05 EDT
Created attachment 348978 [details]
guest.log.gz ....
Comment 4 William A. Mahaffey III 2009-06-22 15:20:53 EDT
[root@athloncube:/etc, Mon Jun 22, 02:24 PM] 1212 # grep virt-manager LIST.installed
virt-manager.x86_64                    0.7.0-5.fc11                    installed
[root@athloncube:/etc, Mon Jun 22, 02:26 PM] 1213 # grep python-virtinst LIST.installed
python-virtinst.noarch                 0.400.3-8.fc11                  installed
[root@athloncube:/etc, Mon Jun 22, 02:26 PM] 1214 # grep libvirt LIST.installed
libvirt.x86_64                         0.6.2-11.fc11                   installed
libvirt-python.x86_64                  0.6.2-11.fc11                   installed
[root@athloncube:/etc, Mon Jun 22, 02:26 PM] 1215 # grep qemu-system-x86 LIST.installed
qemu-system-x86.x86_64                 2:0.10.5-3.fc11                 installed
[root@athloncube:/etc, Mon Jun 22, 02:26 PM] 1216 #




need anything else, don't hesitate ....
Comment 5 Mark McLoughlin 2009-06-23 10:34:32 EDT
Okay, nothing interesting in the logs and I have tried this recently and it works well for me - the only difference is that I used and ISO instead of a physical cd-rom

e.g.

  $> dd if=/dev/sr0 of=/tmp/winxp.iso

and try again?

If that works, it will help narrow down the problem. Thanks
Comment 6 William A. Mahaffey III 2009-06-23 13:06:53 EDT
Created attachment 349115 [details]
new virt-manager.log file ....

here is the newer virt-manager.log file trying to use the iso in /tmp ratherr than through the DVD drive ....
Comment 7 William A. Mahaffey III 2009-06-23 13:07:39 EDT
still nogo, but different behavior ....
Comment 8 Mark McLoughlin 2009-06-24 08:52:52 EDT
Okay, your attempt to install with the ISO failed with:

  Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: char device redirected to /dev/pts/23

What was in /var/log/libvirt/qemu/WinXP.log this time?
Comment 9 William A. Mahaffey III 2009-06-24 09:58:38 EDT
Sorry, I should have included that last time. I just tried again this A.M. & it shows:


[root@athloncube:/etc, Wed Jun 24, 08:58 AM] 1079 # ll /var/log/libvirt/qemu/WinXP.log
1155208 4 -rw-r--r--. 1 root root 562 Jun 24 08:57 /var/log/libvirt/qemu/WinXP.log
[root@athloncube:/etc, Wed Jun 24, 08:58 AM] 1080 # cat /var/log/libvirt/qemu/WinXP.log
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name WinXP -uuid 1900af4c-bc04-d822-9fef-912a3d584de8 -monitor pty -pidfile /var/run/libvirt/qemu//WinXP.pid -localtime -no-reboot -no-acpi -boot d -drive file=/home/VMs/hda.img,if=ide,index=0 -drive file=/tmp/winxp.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:14:40:12,vlan=0 -net tap,fd=18,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 
char device redirected to /dev/pts/22
char device redirected to /dev/pts/23
[root@athloncube:/etc, Wed Jun 24, 08:58 AM] 1081 #

uname -a shows:

Linux athloncube.cfd.com 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 10 William A. Mahaffey III 2009-06-24 10:00:24 EDT
Created attachment 349242 [details]
virt-manager.log from this A.M., consistent w/ last post about WinXP guest log ....

Here is the virt-manager.log from this AM, consistent w/ the WinXP guest log from a few minutes ago ....
Comment 11 Mark McLoughlin 2009-06-24 12:59:19 EDT
Unlike the last time you tried with an iso, this virt-manager.log doesn't show the guest failing to start and your /var/log/libvirt/qemu/WinXP.log doesn't show any errors either.

What happened this time? Did the guest hang like it did when you were using /dev/sr0?
Comment 12 William A. Mahaffey III 2009-06-24 15:33:45 EDT
yes, it hung. The little progress dialog w/ the progress thingy that bounces back & forth hung about 10 sec. in (stopped bouncing), it said 'Creating domain...' right above the progress bar, then came up w/ an error dialog about 5 min. later. I sent the above files several minutes in, but before the last error dialog (I got jumpy, thought it was permanently hung again, wanted to get the info in ASAP, sorry) .... I could try it again & wait until the end & send that if you want, please advise ....
Comment 13 Mark McLoughlin 2009-07-03 03:22:51 EDT
Yes, please try again using an ISO - there were no details of that error in ~/.virt-manager/virt-manager.log

Please try and trim virt-manager.log to the relevant bits - e.g. by moving the existing log out of the way before you do the steps needed to reproduce the bug

Thanks
Comment 14 William A. Mahaffey III 2009-07-03 09:02:42 EDT
Very well, I just deleted the existing virt-manager.log file & kicked off the process again. How long would you expect it to take to create the new VM ? I have waited as long as 24 hours recently just to make totally sure it was hosed ....
Comment 15 Mark McLoughlin 2009-07-03 10:41:22 EDT
(In reply to comment #12)
> yes, it hung. The little progress dialog w/ the progress thingy that bounces
> back & forth hung about 10 sec. in (stopped bouncing), it said 'Creating
> domain...' right above the progress bar, then came up w/ an error dialog about
> 5 min. later.

Okay, that sounds like an anaconda error - could you attach a screenshot of that dialog?
Comment 16 William A. Mahaffey III 2009-07-03 16:39:13 EDT
Created attachment 350457 [details]
screen shot of virt-manager at the moment of death ....

Here you go (screenshot of proceedings when hang occurs) ....
Comment 17 William A. Mahaffey III 2009-07-09 11:19:06 EDT
Update: I had been trying this w/ an externally prepared (by qemu-img) disk image, using the QCOW2 format. When I removed that file & just let virt-manager do its thing all by itself, it (mostly) worked. It did get a VM setup & booted, although there are a few configuration issues (I can't get the VM rebooted once I exit virt-manager, I would like to install the VM image in a dir of my choosing instead of /var/lib/whatever, & the networking isn't working yet). I think these issues are probably mailing list fodder, so .... is there a fedora-virt-manager or kvm mailing list ? Otherwise, I think you can mark this bug .... squashed.
Comment 18 Mark McLoughlin 2009-08-07 08:34:57 EDT
Sorry for the delay in replying

There's a fedora-virt mailing list, see:

  https://fedoraproject.org/wiki/Virtualization#Mailing_List_.26_IRC

I'm going to close this bug for since there's so much back and forth about different issues

However, the issue of virt-manager not being able to use your prepared qcow2 file sounds like it might be worth filing as a new, separate bug if you can still reproduce

Thanks
Comment 19 William A. Mahaffey III 2009-08-07 09:55:02 EDT
OK, but 1 lingering question .... how long should it take to create the new VM (roughly) ? I.e. how long do I wait before declaring it *HUNG* ?
Comment 20 Mark McLoughlin 2009-08-07 10:18:51 EDT
Good question - I would have said 1 minute would be enough, but I see above that you got an error message after waiting 5 minutes

10 minutes, then? I dunno, really
Comment 21 William A. Mahaffey III 2009-08-07 10:23:32 EDT
I just tried again (w/ qcow2 disk image) & it looks like it is hung again. Want it filed separately ?
Comment 22 Mark McLoughlin 2009-08-07 10:37:27 EDT
Yes, please - one bug per issue; i.e. file a new bug for the "cannot use existing qcow2 disk image" and other separate bugs for any other issues you find

Thanks

Note You need to log in before you can comment on or make changes to this bug.