Bug 507075 - inconsistent use of tabs and spaces in indentation in executil, simpleconfig
inconsistent use of tabs and spaces in indentation in executil, simpleconfig
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 11:14 EDT by Anil Seth
Modified: 2009-07-01 13:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 13:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
executil.py with tabs replaced by spaces (8.00 KB, application/octet-stream)
2009-06-29 12:27 EDT, Anil Seth
no flags Details
simpleconfig.py with tabs replaced by 4 spaces (2.31 KB, application/octet-stream)
2009-06-29 12:30 EDT, Anil Seth
no flags Details
translate.py with tabs replaced by 4 spaces (6.75 KB, application/octet-stream)
2009-06-29 12:35 EDT, Anil Seth
no flags Details

  None (edit)
Description Anil Seth 2009-06-20 11:14:08 EDT
Description of problem:
executil, simpleconfig report 
TabError: inconsistent use of tabs and spaces in indentation

Version-Release number of selected component (if applicable):
rhpl-0.221-1.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.sudo livecd-creator --config=/usr/share/spin-kickstarts/fedora-livecd-desktop.ks --fslabel=Fedora-LiveCD --cache=/var/cache/live
2.
3.
  
Actual results:
Import of executil fails. Fixed that, then import of simpleconfig fails

Expected results:
livecd-creator should run.

Additional info:
Comment 1 Chris Lumens 2009-06-29 11:05:13 EDT
Can you attach the exact tracebacks you're receiving, or at least how you patches rhpl to get around it?  Thanks.
Comment 2 Anil Seth 2009-06-29 12:27:18 EDT
Created attachment 349812 [details]
executil.py with tabs replaced by spaces
Comment 3 Anil Seth 2009-06-29 12:30:32 EDT
Created attachment 349816 [details]
simpleconfig.py with tabs replaced by 4 spaces
Comment 4 Anil Seth 2009-06-29 12:35:54 EDT
Created attachment 349819 [details]
translate.py with tabs replaced by 4 spaces
Comment 5 Anil Seth 2009-06-29 12:51:42 EDT
Sorry about the many messages.

I had just used IDLE to replace the tabs by  4 spaces. In some cases, I had to change the indentation to what I thought was reasonable. Since I wasn't sure whether my interpretation was correct, I had not attached the files.

Regards
Anil
Comment 6 Chris Lumens 2009-07-01 13:18:29 EDT
Since we are in the process of removing rhpl (bug 508951), this bug report is no longer relevant.  Thanks for filing it, though.

Note You need to log in before you can comment on or make changes to this bug.