Bug 507079 - Application crash while disconnect a mobile broadband connection
Application crash while disconnect a mobile broadband connection
Status: CLOSED DUPLICATE of bug 500954
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 12:25 EDT by A S Alam
Modified: 2013-07-02 20:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 04:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2009-06-20 12:25:23 EDT
Description of problem:
this is happening only with my Wireless Broadband connection, while disconnect it. If disconnect Wired connection (Ethernet), no problem.
Broadband connection is based on CDMA USB modem. 

Version-Release number of selected component (if applicable):
NetworkManager-0.7.1-4.git20090414.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Use Mobile Broadband connection to connect
2. try to disconnect connection
3. may need to wait for few seconds (4-10)
  
Actual results:
NetworkManger Application crash and Notification Area icon lost

Expected results:
should not crash

Additional info:
Adding back trace, not sure if it is complete. Please let me know if need more
-----------
$cat /var/log/messages
Jun 20 21:37:13 aalam NetworkManager: <info>  (ttyUSB1): device state change: 8 -> 3
Jun 20 21:37:13 aalam NetworkManager: <info>  (ttyUSB1): deactivating device (reason: 39).
Jun 20 21:37:13 aalam pppd[3591]: Terminating on signal 15
Jun 20 21:37:13 aalam pppd[3591]: Connect time 15.3 minutes.
Jun 20 21:37:13 aalam pppd[3591]: Sent 740757 bytes, received 3280424 bytes.
Jun 20 21:37:13 aalam NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Jun 20 21:37:13 aalam NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Jun 20 21:37:13 aalam dbus: Rejected send message, 3 matched rules; type="error", sender=":1.8" (uid=0 pid=1990 comm="NetworkManager --pid-file=/var/run/NetworkManager/") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.76" (uid=0 pid=3591 comm="/usr/sbin/pppd nodetach lock nodefaultroute user 9"))
Jun 20 21:37:13 aalam dbus: Rejected send message, 3 matched rules; type="error", sender=":1.8" (uid=0 pid=1990 comm="NetworkManager --pid-file=/var/run/NetworkManager/") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.76" (uid=0 pid=3591 comm="/usr/sbin/pppd nodetach lock nodefaultroute user 9"))
Jun 20 21:37:13 aalam dbus: Rejected send message, 3 matched rules; type="error", sender=":1.8" (uid=0 pid=1990 comm="NetworkManager --pid-file=/var/run/NetworkManager/") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.76" (uid=0 pid=3591 comm="/usr/sbin/pppd nodetach lock nodefaultroute user 9"))
Jun 20 21:37:17 aalam NetworkManager: <WARN>  nm_signal_handler(): Caught signal 11.  Generating backtrace...
Jun 20 21:37:17 aalam NetworkManager: ******************* START **********************************
Jun 20 21:37:17 aalam NetworkManager: [Thread debugging using libthread_db enabled]
Jun 20 21:37:17 aalam NetworkManager: [New Thread 0x7f64f6505910 (LWP 2837)]
Jun 20 21:37:17 aalam NetworkManager: 0x000000369be0e9dd in waitpid () from /lib64/libpthread.so.0
Jun 20 21:37:17 aalam NetworkManager: #0  0x000000369be0e9dd in waitpid () from /lib64/libpthread.so.0
Jun 20 21:37:17 aalam NetworkManager: #1  0x0000000000430493 in nm_logging_backtrace ()
Jun 20 21:37:17 aalam NetworkManager: #2  0x000000000042b300 in ?? ()
Jun 20 21:37:17 aalam NetworkManager: #3  <signal handler called>
Jun 20 21:37:17 aalam NetworkManager: #4  0x0000000000451710 in ?? ()
Jun 20 21:37:17 aalam NetworkManager: #5  0x00000033f5c3824b in ?? () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: #6  0x00000033f5c37afe in g_main_context_dispatch ()
Jun 20 21:37:17 aalam NetworkManager:    from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: #7  0x00000033f5c3b1d8 in ?? () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: #8  0x00000033f5c3b635 in g_main_loop_run () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: #9  0x000000000042bc66 in main ()
Jun 20 21:37:17 aalam NetworkManager: 
Jun 20 21:37:17 aalam NetworkManager: Thread 2 (Thread 0x7f64f6505910 (LWP 2837)):
Jun 20 21:37:17 aalam NetworkManager: #0  0x000000369be0ddcb in read () from /lib64/libpthread.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #1  0x00000033f5c38aeb in ?? () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #2  0x00000033f5c608b4 in ?? () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #3  0x000000369be0686a in start_thread () from /lib64/libpthread.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #4  0x000000369b2de25d in clone () from /lib64/libc.so.6
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #5  0x0000000000000000 in ?? ()
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: 
Jun 20 21:37:17 aalam NetworkManager: Thread 1 (Thread 0x7f64f6506740 (LWP 1990)):
Jun 20 21:37:17 aalam NetworkManager: #0  0x000000369be0e9dd in waitpid () from /lib64/libpthread.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #1  0x0000000000430493 in nm_logging_backtrace ()
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #2  0x000000000042b300 in ?? ()
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #3  <signal handler called>
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #4  0x0000000000451710 in ?? ()
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #5  0x00000033f5c3824b in ?? () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #6  0x00000033f5c37afe in g_main_context_dispatch ()
Jun 20 21:37:17 aalam NetworkManager:    from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #7  0x00000033f5c3b1d8 in ?? () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #8  0x00000033f5c3b635 in g_main_loop_run () from /lib64/libglib-2.0.so.0
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: #9  0x000000000042bc66 in main ()
Jun 20 21:37:17 aalam NetworkManager: No symbol table info available.
Jun 20 21:37:17 aalam NetworkManager: The program is running.  Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]
Jun 20 21:37:17 aalam NetworkManager: ******************* END *******************************
---------
Comment 1 Niels Haase 2009-06-22 17:32:10 EDT
Thanks for filling this bug. Can you please try the version NetworkManager-0.7.1-5.git20090617.fc11 in update-testing and see if the problem is still present. The easy way to install it with all possible dependencies resolved is to use the below statement:

If you want to test the update, you can install it with
su -c 'yum --enablerepo=updates-testing update wpa_supplicant NetworkManager
mobile-broadband-provider-info'. 



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 A S Alam 2009-06-25 02:28:07 EDT
problem got more serious with latest package. I got kernel oops with each time
connect to device. with more testing, if used 'wvdial' to connect once, then
afterward, networkmanagar works fine (after disconnect wvdial and connect with NM).
Comment 3 Niels Haase 2009-06-25 03:54:26 EDT
Maybe it a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=500954

With Kernel 2.6.29.3-140.fc11 there are oops with usb 3G modems reported. Do you see the same or similar oppes?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 A S Alam 2009-06-25 04:47:42 EDT
yes, it is!
Thanks for finding. marking duplicate for 500954

*** This bug has been marked as a duplicate of bug 500954 ***

Note You need to log in before you can comment on or make changes to this bug.