Bug 507105 - selinux/gnome-settings-deamon avc's
selinux/gnome-settings-deamon avc's
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
: 507238 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 17:27 EDT by Dave Jones
Modified: 2015-01-04 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 08:09:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2009-06-20 17:27:18 EDT
SELinux is preventing gnome-settings- (xdm_t) "getattr" hwdata_t.
node=gelk type=AVC msg=audit(1245419991.600:9): avc: denied { getattr } for pid=2337 comm="gnome-settings-" path="/usr/share/hwdata/pnp.ids" dev=dm-0 ino=12009490 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=file node=gelk type=SYSCALL msg=audit(1245419991.600:9): arch=c000003e syscall=5 success=yes exit=0 a0=11 a1=7fff24033140 a2=7fff24033140 a3=1a items=0 ppid=2335 pid=2337 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="gnome-settings-" exe="/usr/libexec/gnome-settings-daemon" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null) 

SELinux is preventing gnome-settings- (xdm_t) "search" hwdata_t.

node=gelk type=AVC msg=audit(1245419991.600:8): avc: denied { search } for pid=2337 comm="gnome-settings-" name="hwdata" dev=dm-0 ino=12009479 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=dir node=gelk type=AVC msg=audit(1245419991.600:8): avc: denied { read } for pid=2337 comm="gnome-settings-" name="pnp.ids" dev=dm-0 ino=12009490 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=file node=gelk type=AVC msg=audit(1245419991.600:8): avc: denied { open } for pid=2337 comm="gnome-settings-" name="pnp.ids" dev=dm-0 ino=12009490 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=file node=gelk type=SYSCALL msg=audit(1245419991.600:8): arch=c000003e syscall=2 success=yes exit=17 a0=3b5f61fb0e a1=0 a2=0 a3=1a items=0 ppid=2335 pid=2337 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="gnome-settings-" exe="/usr/libexec/gnome-settings-daemon" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null) 


SELinux is preventing gnome-settings- (xdm_t) "search" hwdata_t. 

node=gelk type=AVC msg=audit(1245379009.546:6): avc: denied { search } for pid=2333 comm="gnome-settings-" name="hwdata" dev=dm-0 ino=12009479 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=dir node=gelk type=AVC msg=audit(1245379009.546:6): avc: denied { read } for pid=2333 comm="gnome-settings-" name="pnp.ids" dev=dm-0 ino=12009490 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=file node=gelk type=AVC msg=audit(1245379009.546:6): avc: denied { open } for pid=2333 comm="gnome-settings-" name="pnp.ids" dev=dm-0 ino=12009490 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=file node=gelk type=SYSCALL msg=audit(1245379009.546:6): arch=c000003e syscall=2 success=yes exit=17 a0=3b5f61fb0e a1=0 a2=0 a3=1a items=0 ppid=2331 pid=2333 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="gnome-settings-" exe="/usr/libexec/gnome-settings-daemon" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
Comment 1 Miroslav Grepl 2009-06-22 07:55:41 EDT
*** Bug 507238 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2009-06-22 17:52:26 EDT
You can add these rules now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.6.12-57.fc11

Note You need to log in before you can comment on or make changes to this bug.