Bug 507130 - Krusader has problem with unpack *.rar
Krusader has problem with unpack *.rar
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: krusader (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 03:39 EDT by Martin Naď
Modified: 2009-06-21 09:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 09:38:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Naď 2009-06-21 03:39:22 EDT
Description of problem:
Krusader doesn't knows unpack part rar ,when I unpack *.rar(sometime also with *.zip) krusader unpack *.rar for a few seconds he finish with this message:
Access Denited to ~/some/../file 
unrar 3.71 beta 1 freeware Copyright Alexander
Extracting from  ~/some/../file.rar
Enter password (will not be echoed) for ~/some/../file.rar

Permissons are good(mc normal unpacking *.rar arch.)

and write to konsole:
[NSatan@Metallica ~]$ krusader
[NSatan@Metallica ~]$ kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kbuildsycoca4.so
<unknown program name>(12036)/ KStartupInfo::createNewStartupId: creating:  "Metallica;1245568742;475331;12036_TIME0" : "unnamed app"
No protocol specified
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kbuildsycoca4.so
<unknown program name>(12036)/ KStartupInfo::createNewStartupId: creating:  "Metallica;1245568759;426590;12036_TIME0" : "unnamed app"
No protocol specified
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib64/kde4/kio_krarc.so
QApplication::installTranslator: Please instantiate the QApplication object first
kioslave: ####### CRASH ###### protocol = kio_krarc pid = 13687 signal = 11
No protocol specified
No protocol specified
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_knotify4.so
<unknown program name>(13690)/: KUniqueApplication: Cannot find the D-Bus session server:  "dbus-launch failed to autolaunch D-Bus session: No protocol specified
Autolaunch error: X11 initialization failed.
"

<unknown program name>(13689)/: KUniqueApplication: Pipe closed unexpectedly

Version-Release number of selected component (if applicable):
krusader-debuginfo-2.0.0-1.fc11.x86_64
krusader-2.0.0-1.fc11.x86_64
unrar-3.7.8-4.fc11.x86_64

How reproducible:
everytime

Steps to Reproduce:
1.run krusader
2.start unpack *.rar
3.krusader finish with message (see above)
  
Actual results:
Krusader don't unpacking *.rar

Expected results:
Krusader correct unpack *.rar
Comment 1 Martin Naď 2009-06-21 04:53:49 EDT
hapend to me with distri. KDE 4.2.3 and kde-redhat 4.2.90(I use 4.2.90 because plasma from 4.2.3 often hangs)
Comment 2 Martin Naď 2009-06-21 05:18:03 EDT
maybe this is a upstream bug http://sourceforge.net/tracker/index.php?func=detail&aid=2564710&group_id=6488&atid=106488
Comment 3 Marcin Garski 2009-06-21 09:38:28 EDT
Yes, this is a upstream bug. Which is already fixed in Krusader's SVN.

Note You need to log in before you can comment on or make changes to this bug.