Bug 507136 - Networkmanager crashes if user chooses to cancel the creation of a new network connection
Networkmanager crashes if user chooses to cancel the creation of a new networ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 04:10 EDT by Christian Nolte
Modified: 2009-07-24 15:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.7.1-8.git20090708.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 15:45:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2009-06-21 04:10:53 EDT
1) Edit connections
2) Click Add (tested with Ethernet and Wireless)
3) Click Cancel

Crash:

Distribution: Fedora release 11 (Leonidas)
Gnome Release: 2.26.2 2009-06-01 (Red Hat, Inc)
BugBuddy Version: 2.26.0

System: Linux 2.6.29.4-167.fc11.i686.PAE #1 SMP Wed May 27 17:28:22 EDT 2009 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10601901
Selinux: Enforcing
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: Mist
GTK+ Modules: canberra-gtk-module, pk-gtk-module, gnomebreakpad

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0



----------- .xsession-errors ---------------------
** (nm-applet:2252): CRITICAL **: nm_utils_ssid_to_utf8: assertion `ssid != NULL' failed
** (nm-applet:2252): CRITICAL **: nm_utils_ssid_to_utf8: assertion `ssid != NULL' failed
** (nm-applet:2252): CRITICAL **: nm_utils_ssid_to_utf8: assertion `ssid != NULL' failed
** (nm-applet:2252): CRITICAL **: nm_utils_ssid_to_utf8: assertion `ssid != NULL' failed
** (nm-applet:2252): CRITICAL **: nm_utils_ssid_to_utf8: assertion `ssid != NULL' failed
** (nm-applet:2252): CRITICAL **: nm_utils_ssid_to_utf8: assertion `ssid != NULL' failed
(nm-connection-editor:23390): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
**
ERROR:nm-connection-list.c:744:add_done_cb: code should not be reached
--------------------------------------------------
Comment 1 Niels Haase 2009-06-22 18:45:49 EDT
Thanks for filling this bug. I can confirm this behaviour in NM version NetworkManager-0.7.1-4.git20090414.fc11. After try to add an wired/wireless connection and click on cancel, the complete "Network Connections" window disappear and the "ERROR:nm-connection-list.c:744:add_done_cb: code should not be reached" is shown in the .xsession-errors.

But the problem is already solved in version NetworkManager-0.7.1-5.git20090617.fc11 in updates-testing.

If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant NetworkManager
mobile-broadband-provider-info'.  

You can provide feedback for this update
here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Christian Nolte 2009-06-23 11:44:33 EDT
I can confirm that this problem is fixed. Thanks!
Comment 3 Fedora Update System 2009-06-26 22:41:54 EDT
wpa_supplicant-0.6.8-4.fc11, NetworkManager-0.7.1-5.git20090617.fc11, mobile-broadband-provider-info-0.20090602-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant NetworkManager mobile-broadband-provider-info'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769
Comment 4 Fedora Update System 2009-07-02 01:44:06 EDT
wpa_supplicant-0.6.8-4.fc11, mobile-broadband-provider-info-0.20090602-2.fc11, NetworkManager-0.7.1-6.git20090617.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant mobile-broadband-provider-info NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769
Comment 5 Fedora Update System 2009-07-16 03:07:30 EDT
NetworkManager-0.7.1-8.git20090708.fc11, mobile-broadband-provider-info-1.20090707-1.fc11, wpa_supplicant-0.6.8-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager mobile-broadband-provider-info wpa_supplicant'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769
Comment 6 MarcH 2009-07-16 10:35:19 EDT
Exact same bug in Fedora 10  NetworkManager-0.7.1-1.fc10
Comment 7 Fedora Update System 2009-07-24 15:44:43 EDT
NetworkManager-0.7.1-8.git20090708.fc11, mobile-broadband-provider-info-1.20090707-1.fc11, wpa_supplicant-0.6.8-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.