Bug 507238 - SELinux is preventing gnome-settings- (xdm_t) "search" hwdata_t
SELinux is preventing gnome-settings- (xdm_t) "search" hwdata_t
Status: CLOSED DUPLICATE of bug 507105
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 17:34 EDT by Joseph D. Wagner
Modified: 2009-06-22 07:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 07:55:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph D. Wagner 2009-06-21 17:34:04 EDT
Summary:

SELinux is preventing gnome-settings- (xdm_t) "search" hwdata_t.

Detailed Description:

SELinux denied access requested by gnome-settings-. It is not expected that this
access is required by gnome-settings- and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:hwdata_t:s0
Target Objects                /usr/share/hwdata [ dir ]
Source                        gnome-settings-
Source Path                   /usr/libexec/gnome-settings-daemon
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           gnome-settings-daemon-2.26.1-7.fc11
Target RPM Packages           hwdata-0.225-1.fc11
Policy RPM                    selinux-policy-3.6.12-50.fc11
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27
                              17:27:08 EDT 2009 x86_64 x86_64
Alert Count                   5
First Seen                    Sat 20 Jun 2009 02:04:52 AM PDT
Last Seen                     Sun 21 Jun 2009 01:45:43 PM PDT
Local ID                      a707923f-ca65-4cb8-8972-6e492de67948
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1245617143.422:12): avc:  denied  { search } for  pid=1874 comm="gnome-settings-" name="hwdata" dev=sdb5 ino=27618 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hwdata_t:s0 tclass=dir

node=localhost.localdomain type=SYSCALL msg=audit(1245617143.422:12): arch=c000003e syscall=2 success=no exit=-13 a0=3801c1fb0e a1=0 a2=0 a3=1a items=0 ppid=1872 pid=1874 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="gnome-settings-" exe="/usr/libexec/gnome-settings-daemon" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
Comment 1 Miroslav Grepl 2009-06-22 07:55:40 EDT

*** This bug has been marked as a duplicate of bug 507105 ***

Note You need to log in before you can comment on or make changes to this bug.