Bug 507252 - BUG: Bad page state in process gnome-keyring-d pfn:11ee9f, and other processes, on shutdown
BUG: Bad page state in process gnome-keyring-d pfn:11ee9f, and other process...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 20:20 EDT by Tom London
Modified: 2009-08-19 09:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 09:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages for complete session showing BUGs (174.91 KB, text/plain)
2009-06-21 20:20 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2009-06-21 20:20:47 EDT
Created attachment 348830 [details]
/var/log/messages for complete session showing BUGs

Description of problem:
I noticed the following BUGs in /var/log/messages after a normal shutdown of kernel-2.6.31-0.17.rc0.git15.fc12.x86_64.

I count about 44 of them.  I insert the first two here.

I attach a complete session's worth of /var/log/messages for all of them.

Jun 21 17:10:22 tlondon kernel: BUG: Bad page state in process gnome-keyring-d  pfn:11ee9f
Jun 21 17:10:22 tlondon kernel: page:ffffea000748f098 flags:004000000050000c count:0 mapcount:0 mapping:(null) index:7fe3396ea
Jun 21 17:10:22 tlondon kernel: Pid: 2230, comm: gnome-keyring-d Tainted: G        W  2.6.31-0.17.rc0.git15.fc12.x86_64 #1
Jun 21 17:10:22 tlondon kernel: Call Trace:
Jun 21 17:10:22 tlondon kernel: [<ffffffff810fa7d5>] bad_page+0x11a/0x143
Jun 21 17:10:22 tlondon kernel: [<ffffffff8109385e>] ? trace_hardirqs_on_caller+0x32/0x175
Jun 21 17:10:22 tlondon kernel: [<ffffffff810faa5f>] free_pages_check+0x41/0x72
Jun 21 17:10:22 tlondon kernel: [<ffffffff810fc054>] free_hot_cold_page+0x53/0x1e6
Jun 21 17:10:22 tlondon kernel: [<ffffffff810fc228>] __pagevec_free+0x41/0x6a
Jun 21 17:10:22 tlondon kernel: [<ffffffff81100529>] release_pages+0x1c2/0x1e8
Jun 21 17:10:22 tlondon kernel: [<ffffffff8111ba2a>] ? anon_vma_unlink+0x33/0x7e
Jun 21 17:10:22 tlondon kernel: [<ffffffff8111f5de>] free_pages_and_swap_cache+0x72/0xa3
Jun 21 17:10:22 tlondon kernel: [<ffffffff81115c54>] tlb_finish_mmu+0x46/0x68
Jun 21 17:10:22 tlondon kernel: [<ffffffff81115d83>] unmap_region+0x10d/0x130
Jun 21 17:10:22 tlondon kernel: [<ffffffff811174ad>] do_munmap+0x2bd/0x33b
Jun 21 17:10:22 tlondon kernel: [<ffffffff81117576>] ? sys_munmap+0x4b/0x86
Jun 21 17:10:22 tlondon kernel: [<ffffffff81117584>] sys_munmap+0x59/0x86
Jun 21 17:10:22 tlondon kernel: [<ffffffff81012f42>] system_call_fastpath+0x16/0x1b
Jun 21 17:10:22 tlondon kernel: BUG: Bad page state in process gnome-keyring-d  pfn:11ee9e
Jun 21 17:10:22 tlondon kernel: page:ffffea000748f030 flags:004000000050000c count:0 mapcount:0 mapping:(null) index:7fe3396e9
Jun 21 17:10:22 tlondon kernel: Pid: 2230, comm: gnome-keyring-d Tainted: G    B   W  2.6.31-0.17.rc0.git15.fc12.x86_64 #1
Jun 21 17:10:22 tlondon kernel: Call Trace:
Jun 21 17:10:22 tlondon kernel: [<ffffffff810fa7d5>] bad_page+0x11a/0x143
Jun 21 17:10:22 tlondon kernel: [<ffffffff8109385e>] ? trace_hardirqs_on_caller+0x32/0x175
Jun 21 17:10:22 tlondon kernel: [<ffffffff810faa5f>] free_pages_check+0x41/0x72
Jun 21 17:10:22 tlondon kernel: [<ffffffff810fc054>] free_hot_cold_page+0x53/0x1e6
Jun 21 17:10:22 tlondon kernel: [<ffffffff810fc228>] __pagevec_free+0x41/0x6a
Jun 21 17:10:22 tlondon kernel: [<ffffffff81100529>] release_pages+0x1c2/0x1e8
Jun 21 17:10:22 tlondon kernel: [<ffffffff8111ba2a>] ? anon_vma_unlink+0x33/0x7e
Jun 21 17:10:22 tlondon kernel: [<ffffffff8111f5de>] free_pages_and_swap_cache+0x72/0xa3
Jun 21 17:10:22 tlondon kernel: [<ffffffff81115c54>] tlb_finish_mmu+0x46/0x68
Jun 21 17:10:22 tlondon kernel: [<ffffffff81115d83>] unmap_region+0x10d/0x130
Jun 21 17:10:22 tlondon kernel: [<ffffffff811174ad>] do_munmap+0x2bd/0x33b
Jun 21 17:10:22 tlondon kernel: [<ffffffff81117576>] ? sys_munmap+0x4b/0x86
Jun 21 17:10:22 tlondon kernel: [<ffffffff81117584>] sys_munmap+0x59/0x86
Jun 21 17:10:22 tlondon kernel: [<ffffffff81012f42>] system_call_fastpath+0x16/0x1b
Jun 21 17:10:23 tlondon init: tty6 main process (1864) killed by TERM signal


Version-Release number of selected component (if applicable):
kernel-2.6.31-0.17.rc0.git15.fc12.x86_64

How reproducible:
Looks like every shutdown

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-08-19 09:57:14 EDT
Haven't seen one of these in ages....

Closing.

Note You need to log in before you can comment on or make changes to this bug.