Bug 507274 - fedora core 11 install fails at partition editor 'parted' geometry during anaconda install
fedora core 11 install fails at partition editor 'parted' geometry during an...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 01:15 EDT by collura
Modified: 2009-12-16 08:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 08:34:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump generated when install fails (144.83 KB, text/plain)
2009-06-22 01:15 EDT, collura
no flags Details
sorry tired....her is dmesg to help get idea of devices on machine (43.01 KB, text/plain)
2009-06-22 01:21 EDT, collura
no flags Details

  None (edit)
Description collura 2009-06-22 01:15:57 EDT
Created attachment 348852 [details]
dump generated when install fails

Description of problem:

fedora core-11 live cd (similarly with install dvd) crashes during install on a toshiba satellite notebook model#L355D-S7901.

while attempting to setup disk partitions during the install process there is a failure.

if i am reading this right then it seems that the during anaconda the 'parted' identifies a usb hub as a drive and then fails when it cant figure out what to do with it?  


Following are snipets from attachted files:

...

File "/usr/lib64/python2.6/site-packages/parted/geometry.py", line 128, in intersect
    return Geometry(PedGeometry=self.__geometry.intersect(b.getPedGeometry()))

...

CreateException: Error opening /dev/sdb: No medium found

...

[2009-06-21 17:07:59,932]    DEBUG: scanning sdb (/devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/host8/target8:0:0/8:0:0:0/block/sdb)...
[2009-06-21 17:07:59,933]    DEBUG: looking for device 'sdb'...
[2009-06-21 17:07:59,933]    DEBUG: found None
[2009-06-21 17:07:59,935]    DEBUG: sdb is a disk
[2009-06-21 17:07:59,935]    DEBUG: getFormat('None') returning DeviceFormat instance
[2009-06-21 17:07:59,938]    DEBUG: looking up parted Device: /dev/sdb
[2009-06-21 17:07:59,938]    DEBUG: looking up parted Device: /dev/sdb
[2009-06-21 17:07:59,946]    DEBUG: added sdb (disk) to device tree
[
... .


expected action: partition resized and fc11 installs

actual action: 'parted' crashes during anaconda of fc11 install

repeatability: always

Steps:

boot ok off of liveCD or instalDVD and go through steps of install until get to partition editor to shrink an existing nfts partition to create freespace for dualboot system.

choose to 'shrink existing partition' (or to 'create an install using freespace' and then attempt to resize an existing partition to make room to create a partition)
go through the dialogs until parted fails 

Aditional Info:

this basically looked the close to bug#495433 ('i386 anaconda problem') and bug#505750 ('i386 anaconda problem') and bug#506807 ('x86-64 anaconda problem') but refiled here because seemed less like an anaconda problem but rather a parteditor problem.  hopefully this is helpful and not detracting.

see attachments
Comment 1 collura 2009-06-22 01:19:46 EDT
hmm was going to add a file with bootmessage to shed light on device configuration but dont see where to add second file..so let me know if you would like.
Comment 2 collura 2009-06-22 01:21:57 EDT
Created attachment 348853 [details]
sorry tired....her is dmesg to help get idea of devices on machine
Comment 3 Joel Andres Granados 2009-07-22 09:21:40 EDT
What does `parted DEVICE print free` spit out.  You can execute this while in the installer.  Also note that there is a new parted in fedora, the latest version is parted-1.9.0-5.20090721git980c
Comment 4 collura 2009-09-17 18:34:59 EDT
sorry for delay.

no luck.

system disk is fully partitioned now from f10 install but ran the following
from a terminal window from the fc11 live cd (download image dated june) that i had used for the bug report:

'parted DEVICE print free' which from the man page i think is supposed to refer to default device but gave me 'error could not stat device DEVICE'

'parted /dev/sdb print free' gave me 'parted: invalid token: parted'


[root@localhost liveuser]# parted /dev/sda
GNU Parted 1.8.8
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print free                                                       
Model: ATA FUJITSU MHZ2250B (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags 
        32.3kB  1049kB  1016kB            Free Space         
 1      1049kB  1574MB  1573MB  primary   ntfs               
 2      1574MB  55.0GB  53.4GB  primary   ntfs         boot  
        55.0GB  55.0GB  3914kB            Free Space         
 4      55.0GB  244GB   189GB   extended                     
 5      55.0GB  55.2GB  230MB   logical   ext3               
 6      55.2GB  58.6GB  3381MB  logical                      
 7      58.6GB  244GB   185GB   logical                      
        244GB   244GB   2491kB            Free Space         
 3      244GB   250GB   6333MB  primary   ntfs         hidden

(parted)                            



downloaded a fresh version of the fedora-core-11-livecd few days ago and it also was dated june (all the mirrors i checkes were same) and uses parted 1.8.8 instead of the 1.9 you suggested is available.  cant wait for my next system crash to have to get around to making my own livecd lol.
Comment 5 collura 2009-12-01 20:44:02 EST
fyi, did an install of fc12 last week and although didnt resize any partitions i did overwrite them and formated them to ext4 in the process.  the install went great.  not sure if this helps since i didnt try a resize.
Comment 6 Hans de Goede 2009-12-16 08:34:14 EST
(In reply to comment #5)
> fyi, did an install of fc12 last week and although didnt resize any partitions
> i did overwrite them and formated them to ext4 in the process.  the install
> went great.  not sure if this helps since i didnt try a resize.  

Thanks, we indeed have fixed a number of no medium bugs in Fedora-12. These bugs
are not related to resizing or not, so your test confirms this is fixed for your system, closing.

Note You need to log in before you can comment on or make changes to this bug.