Bug 507325 - Input the command "virt-manager -help" in the terminal.There will be a error message
Input the command "virt-manager -help" in the terminal.There will be a error ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: Regression
: 506727 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 07:24 EDT by Qunfang Zhang
Modified: 2011-01-24 19:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:43:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't try to show error info on SystemException (499 bytes, patch)
2009-06-25 11:52 EDT, Cole Robinson
no flags Details | Diff

  None (edit)
Description Qunfang Zhang 2009-06-22 07:24:25 EDT
Description of problem:
Input the command "virt-manager --help" in the terminal.There will be a error message poping up:
Error starting Virtual Machine Manager:0

Version-Release number of selected component (if applicable):
virt-manager-0.6.1-3.el5

How reproducible:
Always

Steps to Reproduce:
1.Input "man virt-manager" command in the terminal.There will be options about "virt-manager -help"
2.Input "virt-manager -help" command in the terminal.

  
Actual results:
There will be a error message poping up:
Error starting Virtual Machine Manager:0

Expected results:
There will be some help information displayed.

Additional info:
Error message details:
Traceback (most recent call last):
 File "/usr/share/virt-manager/virt-manager.py", line 368, in ?
   main()
 File "/usr/share/virt-manager/virt-manager.py", line 270, in main
   (options, ignore) = parse_commandline()
 File "/usr/share/virt-manager/virt-manager.py", line 187, in parse_commandline
   return optParser.parse_args()
 File "/usr/lib64/python2.4/optparse.py", line 1275, in parse_args
   stop = self._process_args(largs, rargs, values)
 File "/usr/lib64/python2.4/optparse.py", line 1315, in _process_args
   self._process_long_opt(rargs, values)
 File "/usr/lib64/python2.4/optparse.py", line 1390, in _process_long_opt
   option.process(opt, value, values, self)
 File "/usr/lib64/python2.4/optparse.py", line 707, in process
   return self.take_action(
 File "/usr/lib64/python2.4/optparse.py", line 729, in take_action
   parser.exit()
 File "/usr/lib64/python2.4/optparse.py", line 1449, in exit
   sys.exit(status)
SystemExit: 0
Comment 2 Cole Robinson 2009-06-25 11:52:55 EDT
Created attachment 349416 [details]
Don't try to show error info on SystemException

This is a regression (though a minor one), so we should fix it for 5.4.
Comment 3 Cole Robinson 2009-06-26 10:07:27 EDT
*** Bug 506727 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2009-06-29 15:04:49 EDT
Being built into virt-manager-0.6.1-5.el5. Setting to MODIFIED.
Comment 7 Chris Ward 2009-07-03 14:46:11 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 10 errata-xmlrpc 2009-09-02 05:43:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1285.html

Note You need to log in before you can comment on or make changes to this bug.