Bug 507409 - Should percent-encode "@" in SMB passwords
Should percent-encode "@" in SMB passwords
Status: CLOSED DUPLICATE of bug 719459
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-printer (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 12:55 EDT by Tim Waugh
Modified: 2012-03-26 11:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 11:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the fix. (485 bytes, patch)
2009-06-22 12:55 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2009-06-22 12:55:01 EDT
Created attachment 348943 [details]
This is the fix.

Description of problem:
The "@" character is not URL-encoded when adding a printer with a device URI like:

smb://user:@password@domain/server/share

(note, the password is "@password", i.e. it has an 'at' sign in it).

The correct URI is:

smb://user:%40password@domain/server/share

Version-Release number of selected component (if applicable):
system-config-printer-0.7.32.10-1.el5

How reproducible:
100%

Steps to Reproduce:
1.Add an SMB printer at "domain/server/share" with username/password "user"/"@password"
  
Actual results:
not-possible

Expected results:
Printer added, /etc/cups/printers.conf shows correct URI:
smb://user:%40password@domain/server/share

Additional info:
Comment 1 RHEL Product and Program Management 2009-11-06 13:42:07 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2010-08-09 14:11:58 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 Tim Waugh 2012-03-26 11:06:40 EDT

*** This bug has been marked as a duplicate of bug 719459 ***

Note You need to log in before you can comment on or make changes to this bug.