Bug 507433 - Unable to mount filesystem error during installation
Unable to mount filesystem error during installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 14:31 EDT by Andrew McNabb
Modified: 2010-06-28 09:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (41.21 KB, text/plain)
2009-06-22 14:31 EDT, Andrew McNabb
no flags Details
program.log (22.43 KB, text/plain)
2009-06-22 14:39 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2009-06-22 14:31:00 EDT
I got the following error message:

"An error occurred mounting device /dev/sda2 as /: mount failed: (2, None).  This is a fatal error and the install cannot continue."

I tried checking to see whether this was already in Bugzilla.  My bug seems similar to bug 505407 and 492727 but is not the same as either of these.  If I go to another virtual terminal, I cannot successfully mount /dev/sda2 by hand.  I tried specifically setting -t ext3 and -t ext4, but neither worked.

I will attach a few log files that seem relevant.
Comment 1 Andrew McNabb 2009-06-22 14:31:26 EDT
Created attachment 348956 [details]
anaconda.log
Comment 2 Andrew McNabb 2009-06-22 14:39:26 EDT
Created attachment 348958 [details]
program.log

The program.log seems to show that the filesystem was created.
Comment 3 Chris Lumens 2009-06-29 14:59:26 EDT
This sounds like a filesystem bug that I heard rumors of when we were working on F11.  However, I do not know if there's an actual bug report tracking this problem.
Comment 4 Eric Sandeen 2009-10-06 10:26:42 EDT
Somehow this bug totally fell off my radar.  Is this still a problem?  I'm guessing not or people would have screamed at me more ... :)

For next time, though:

> If I go to another virtual terminal, I cannot successfully mount /dev/sda2
> by hand. I tried specifically setting -t ext3 and -t ext4, but neither worked.

the next step is to type "dmesg" and see why the kernel failed to mount it.

-Eric
Comment 5 Andrew McNabb 2009-10-06 12:55:49 EDT
Anaconda bugs are really hard to test, both because reinstalling can be a pain and because new installation initrds are rarely published.  When the Fedora 12 beta comes out, I will definitely keep an eye out for this.
Comment 6 Bug Zapper 2010-04-27 11:10:09 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2010-06-28 09:13:17 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.