Bug 507436 - Module language does not contain a class named moduleClass; skipping.
Module language does not contain a class named moduleClass; skipping.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-language (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Pravin Satpute
QE Internationalization Bugs
:
Depends On: 530698
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 14:33 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
6 users (show)

See Also:
Fixed In Version: system-config-language-1.3.3-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 10:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2009-06-22 14:33:53 EDT
Description of problem:
Getting $Summary when attempting to kick off firstboot with system-config-language-1.3.2-5.fc11.

Version-Release number of selected component (if applicable):
1.3.2-5.fc11

How reproducible:
Always

Steps to Reproduce:
1. Run firstboot and watch the logs
Comment 1 Bill Nottingham 2009-06-23 13:00:09 EDT
Moving to beta target. This has been broken for multiple Fedora releases - do we really care about having this in firstboot?
Comment 2 Chris Lumens 2009-06-30 13:07:26 EDT
No, I don't think this needs to be in firstboot anymore.  It was only ever in reconfig mode, and we've been getting rid of those sorts of things as they come up.
Comment 3 Jay Turner 2009-06-30 14:35:15 EDT
This becomes a request to remove the firstboot functionality from the system-config-language package.
Comment 4 Sebastian Dziallas 2009-07-01 09:32:06 EDT
Oh, interesting to see this! Sugar Labs was trying to incorporate firstboot into Sugar on a Stick (a live media based on Fedora), where language selection would be very helpful. Is there any "easy" way of working around this?

/me understands the point of cleaning up system-config-language, though. ;)
Comment 5 Bill Nottingham 2009-07-01 10:23:20 EDT
Well, for the 'normal' desktop, the language is choosable via GDM. I suppose some sort of sugar-display-manager (or sugar theme for GDM) is overkill?
Comment 6 Sebastian Dziallas 2009-07-01 10:29:56 EDT
Heh. We're doing auto-login through slim right now. That's why we had the idea of having firstboot coming up before, so that the user could select the language, a keyboard profile and chose whether he wanted to submit his information to smolt or not.

One possibility might be to have gdm visible to the user only once and then an auto-login through it...
Comment 7 Jens Petersen 2009-09-09 22:21:31 EDT
Missing some context here - why isn't this a Fedora bug?
Comment 8 Bill Nottingham 2009-09-10 11:11:58 EDT
It was originally filed for the RHEL 6 alpha.
Comment 9 Pravin Satpute 2009-10-27 03:12:11 EDT
do we reach to any conclusion here..
should we remove firstboot support from system-config-language?
i think it will not affect anything much
Comment 10 Jay Turner 2009-10-28 07:05:27 EDT
Looks like this will be resolved by pulling in the F12 package where the functionality has been removed.  Moving this issue to ON_QA and will verify once the package is available in RHEL.
Comment 11 Pravin Satpute 2009-10-28 07:31:09 EDT
thats nice,
good to keep watch on bug #530698 as well
Comment 12 releng-rhel@redhat.com 2009-12-16 16:52:46 EST
Fixed in 'system-config-language-1.3.3-3.fc12'. 'system-config-language-1.3.3-4.el6' included in compose 'RHEL6.0-20091216.nightly'.
Moving to ON_QA.
Comment 13 Jay Turner 2010-04-06 10:52:49 EDT
system-config-language-1.3.3-4.el6 included in RHEL6.0-Beta1-3.0.  Closing out.

Note You need to log in before you can comment on or make changes to this bug.