Bug 507509 - The VTE_CJK_WIDTH environment variable is not available in RHEL 5. [NEEDINFO]
The VTE_CJK_WIDTH environment variable is not available in RHEL 5.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vte (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Zeeshan Ali
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 23:48 EDT by Ryo HAYAKAWA
Modified: 2016-09-19 21:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:05:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (ryo)


Attachments (Terms of Use)

  None (edit)
Description Ryo HAYAKAWA 2009-06-22 23:48:31 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

The VTE_CJK_WIDTH environment variable is available in RHEL 4,
but this is not avialble in RHEL 5.

The detail of the VTE_CJK_WIDTH environment variable are in the
following URL.

https://rhn.redhat.com/errata/RHBA-2007-0219.html

The following patch fixes this problem.


Reproducible: Always




--- src/iso2022.c.orig  2006-09-01 04:56:44.000000000 +0900
+++ src/iso2022.c       2009-06-23 12:14:58.000000000 +0900
@@ -399,6 +399,14 @@
                }
        }

+        /*
+         * Decide the ambiguous width according to the default region if
+         * current locale is UTF-8.
+         */
+        if (strcmp (codeset, "utf8") == 0 && g_getenv("VTE_CJK_WIDTH") != NULL)
+          return _vte_iso2022_ambiguous_width_guess ();
+
+
        /* Not in the list => not wide. */
        return 1;
 }
Comment 1 RHEL Product and Program Management 2014-03-07 07:41:54 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:05:10 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.