Bug 507531 - firefox fails to play flash movie with radeon driver (radeon 9200)
firefox fails to play flash movie with radeon driver (radeon 9200)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 04:02 EDT by muteki
Modified: 2009-08-06 03:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 03:32:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.73 KB, text/plain)
2009-06-23 04:02 EDT, muteki
no flags Details
firefox crash log (580.77 KB, text/plain)
2009-06-23 04:44 EDT, muteki
no flags Details
xorg.0.log (57.06 KB, text/plain)
2009-06-23 04:48 EDT, muteki
no flags Details
firefox crash (570.11 KB, text/plain)
2009-06-24 01:29 EDT, muteki
no flags Details
xorg.0.log (56.34 KB, text/plain)
2009-06-24 01:36 EDT, muteki
no flags Details

  None (edit)
Description muteki 2009-06-23 04:02:46 EDT
Created attachment 349053 [details]
xorg.conf

Description of problem:
Starting up kernel with "nomodeset" (couldn't bring up X at all with it), bring up firefox and go to youtube.  Select any youtube movie.  When the movie about to start (after a brief buffering), firefox crashes.  The next time I startup firefox and go to the same site, I got the grey out box for the flash object  (appears flash-plugin got disabled).

Version-Release number of selected component (if applicable):
2.6.29.4-167.fc11.i586 #1 SMP
xorg-x11-drv-ati-6.12.2-17.fc11.i586
firefox-3.5-0.20.beta4.fc11.i586
flash-plugin-10.0.22.87-release.i386
01:00.0 VGA compatible controller: ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200 (AGP)] (rev 01)

How reproducible:
100%

Steps to Reproduce:
1. start up kernel with "nomodeset"
2. start firefox
3. go to youtube
4. select any flash movie
  
Actual results:
firefox crashes

Expected results:
movie plays normally

Additional info:
Everything was working fine with fedora 10.  Without "nomodeset" in the cmdline, X fails to start up (separate issue).
Comment 1 muteki 2009-06-23 04:44:42 EDT
Created attachment 349062 [details]
firefox crash log

I gave out wrong information.  When firefox crashes, the system is with xorg-x11-drv-ati-6.12.2-15.fc11.  Attached is the crash log from firefox.  After upgrading to xorg-x11-drv-ati-6.12.2-17.fc11, I can no longer reproduce the crash.  But flash object still remains as grey out area.
Comment 2 muteki 2009-06-23 04:48:40 EDT
Created attachment 349064 [details]
xorg.0.log

Seems like direct rendering is on according to glxinfo.  But Xorg.0.log has errors about DRI.

[root@suita ~]# glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Software Rasterizer
Comment 3 muteki 2009-06-23 04:54:31 EDT
Checked Common F11 bugs and tried both:

Option "AccelMethod" "XAA"
Option "AccelDFS" "off"

doesn't resolve the issue I am seeing.
Comment 4 Matěj Cepl 2009-06-23 13:55:49 EDT
Would

Option "DRI" "off"

help? (our last offspring in the collection of fixing tips)
Comment 5 muteki 2009-06-24 01:29:30 EDT
Created attachment 349192 [details]
firefox crash

No, it doesn't work for me.  This time, firefox crashes again with DRI disabled.
Comment 6 muteki 2009-06-24 01:36:41 EDT
Created attachment 349193 [details]
xorg.0.log

Even though Xorg.0.log seems to indicate DRI is disabled, glxinfo says something else.  Not sure which one is correct.

[root@suita ~]# grep DRI /var/log/Xorg.0.log
(II) Loading extension XFree86-DRI
(II) Loading extension DRI2
(**) RADEON(0): Option "DRI" "false"
(II) AIGLX: Screen 0 is not DRI2 capable
(II) AIGLX: Screen 0 is not DRI capable
(II) GLX: Initialized DRISWRAST GL provider for screen 0

[root@suita ~]# glxinfo | grep direct
direct rendering: Yes
Comment 7 Matěj Cepl 2009-06-24 10:59:32 EDT
(In reply to comment #6)
> Even though Xorg.0.log seems to indicate DRI is disabled, glxinfo says
> something else.  Not sure which one is correct.
> 
> [root@suita ~]# grep DRI /var/log/Xorg.0.log
> (II) Loading extension XFree86-DRI
> (II) Loading extension DRI2
> (**) RADEON(0): Option "DRI" "false"
> (II) AIGLX: Screen 0 is not DRI2 capable
> (II) AIGLX: Screen 0 is not DRI capable
> (II) GLX: Initialized DRISWRAST GL provider for screen 0
> 
> [root@suita ~]# glxinfo | grep direct
> direct rendering: Yes  

Both are. Message

direct rendering: Yes

says just that DRI protocol is supported; in this case we don't do it hardware-wise, but emulate DRI hardware with software (see that DRISWRAST line). This will be really slow. So, although DRI is supported I wouldn't try if I were you to run compiz now (for example).
Comment 8 muteki 2009-06-25 01:31:51 EDT
Thanks for the info.  Given disabling DRI doesn't help my situation and it will make performance worse, I will take out that option.

May I know what's the next thing I can try to get flash working on firefox?
Comment 9 muteki 2009-08-06 03:32:07 EDT
The flash problem turns out to be caused by the legacy libflashsupport package from earlier install.  Removing that fixes that issue.  I also found out I can remove the nomodeset and get the hardware acceleration working by changing the Vaio's BIOS settings.  (set LCD screen expansion to yes)

Marked this bug as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.