Bug 507557 - freeipmi-ipmidetectd %post scriptlet failure
freeipmi-ipmidetectd %post scriptlet failure
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: freeipmi (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Jan Safranek
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 06:20 EDT by Alexander Todorov
Modified: 2010-11-11 09:39 EST (History)
3 users (show)

See Also:
Fixed In Version: freeipmi-0.7.10-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:39:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-06-23 06:20:40 EDT
Description of problem:

Error(s): Installing freeipmi-ipmidetectd-0.7.8-1.fc11.x86_64
warning: %post(freeipmi-ipmidetectd-0.7.8-1.fc11.x86_64) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):
freeipmi-ipmidetectd-0.7.8-1.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. install @everything
2.
3.
  

Additional info:
Comment 2 Alexander Todorov 2009-06-23 07:32:10 EDT
Jan,
I'm seeing similar failure for freeipmi-bmc-watchdog. Let me know if you need another BZ open for it. See the log in comment #1 for more details.

Error(s): Installing freeipmi-bmc-watchdog-0.7.8-1.fc11.x86_64
warning: %post(freeipmi-bmc-watchdog-0.7.8-1.fc11.x86_64) scriptlet failed, exit status 1
Comment 3 Bill Nottingham 2009-06-23 12:15:07 EDT
postinstall scriptlet (using /bin/sh):
if [ "$1" = 1 ]; then
   if [ -x /etc/rc.d/init.d/freeipmi-bmc-watchdog ]; then
      /sbin/chkconfig --add freeipmi-bmc-watchdog
      /sbin/chkconfig freeipmi-bmc-watchdog off

### Why not just set the default to off???

   fi
fi
if [ $1 -ge 1 ]; then
   if [ -x /etc/rc.d/init.d/freeipmi-bmc-watchdog ]; then
      if /etc/rc.d/init.d/freeipmi-bmc-watchdog status | grep -q running; then
         /etc/rc.d/init.d/freeipmi-bmc-watchdog restart
      else
         /etc/rc.d/init.d/freeipmi-bmc-watchdog condrestart
      fi

### This is entirely superfluous. Just do a condrestart; that's the point of it (to restart if running.)

   fi
fi
preuninstall scriptlet (using /bin/sh):
#
# Stop bmc-watchdog if it is running 
#
if [ "$1" = 0 ]; then
    if [ -x /etc/rc.d/init.d/freeipmi-bmc-watchdog ]; then
       if /etc/rc.d/init.d/freeipmi-bmc-watchdog status | grep -q running; then
          /etc/rc.d/init.d/freeipmi-bmc-watchdog stop
       fi
### stop on a not-running service should not be an issue

       /sbin/chkconfig --del freeipmi-bmc-watchdog
    fi
fi

Also, why is this all gated on [ -x <the init script> ]? If you're installing the package, you know you have it.
Comment 4 Jan Safranek 2009-06-29 06:06:56 EDT
(In reply to comment #3)

The .spec is based on upstream one and somehow passed the Fedora review... I'll rewrite all the scripts, based on our well-known and working snippets.

Anyway, I think that the bug is caused by missing "Requires(pre): chkconfig"... I am going to check it soon.
Comment 5 Jan Safranek 2009-06-29 09:36:56 EDT
Reproducible with following kickstart snippet (no need to install everything):

%packages
freeipmi-ipmidetectd
freeipmi-bmc-watchdog
freeipmi-devel
freeipmi
@base
Comment 6 Jan Safranek 2009-06-29 10:22:44 EDT
Fixed in Rawhide, freeipmi-0.7.10-2.fc12.

I have established a yum repo on http://people.redhat.com/jsafrane/bugs/507557/ if you want to test F11 or RHEL6 installation with the updated packages.
Comment 7 releng-rhel@redhat.com 2009-10-28 11:51:13 EDT
Fixed in 'freeipmi-0.7.10-2.fc12'. 'freeipmi-0.7.11-2.el6' included in compose 'RHEL6.0-20091027.3'.
Moving to ON_QA.
Comment 9 releng-rhel@redhat.com 2010-11-11 09:39:11 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.