Bug 507559 - Unlimited-Guest Virtualization Platform Hosts tab shows incorrect data
Unlimited-Guest Virtualization Platform Hosts tab shows incorrect data
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Virtualization (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sebastian Skracic
Red Hat Network Quality Assurance
https://rhn.redhat.com/rhn/systems/en...
US=105799
:
Depends On:
Blocks: 506596
  Show dependency treegraph
 
Reported: 2009-06-23 06:29 EDT by Sebastian Skracic
Modified: 2009-08-10 09:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 09:02:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Skracic 2009-06-23 06:29:03 EDT
Description of problem:

The Unlimited-Guest tab of Virtualization Entitlements page does not display virtualization platform hosts with no guests registered to RHN.  This is confusing and misleading because the displayed content is not reflecting its heading: "The following is a list of host systems with the 'Unlimited Virtualization' entitlement."

Version-Release number of selected component (if applicable):

Current.

How reproducible:

Always.

Steps to Reproduce:
1. Add 'Virtualization Platform' entitlement to one of your hosts registered to RHN.
2. Ensure the above host has no guests defined.
3. Check https://rhn.redhat.com/rhn/systems/entitlements/GuestUnlimitedHosts.do
  
Actual results:

The host is not displayed in the tab.

Expected results:

The host should be displayed in the tab.

Additional info:
Comment 1 Sebastian Skracic 2009-06-23 08:09:34 EDT
The identical problem is present on the 'Virtualization Host' tab as well.  No record is shown for hosts with no guests known to RHN.

https://rhn.redhat.com/rhn/systems/entitlements/GuestLimitedHosts.do
Comment 2 Sebastian Skracic 2009-06-23 08:25:56 EDT
Fixed in bb6ff3cecdce10e88482e50ecc0ac3f85c1427c1.
Comment 3 Sebastian Skracic 2009-06-24 11:21:10 EDT
On DEV.
Comment 4 Denise Hughes 2009-07-23 15:16:31 EDT
Verified in webdev on 06/25/09
Comment 5 Denise Hughes 2009-07-29 15:28:14 EDT
Verified in webqa.

Note You need to log in before you can comment on or make changes to this bug.