Bug 507560 - error when installing jakarta-commons-io
error when installing jakarta-commons-io
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: jakarta-commons-io (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Andrew Overholt
Red Hat Satellite QA List
:
: 540429 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 06:29 EDT by Alexander Todorov
Modified: 2010-04-13 18:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 18:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-06-23 06:29:38 EDT
Description of problem:
Error(s): Installing jakarta-commons-io-1.3.2-2.2.fc11.noarch
/var/tmp/rpm-tmp.L7vzr9: line 4: cat: command not found

This package is installed before coreutils which contains the `cat' command

Version-Release number of selected component (if applicable):
jakarta-commons-io-1.3.2-2.2.fc11.noarch

How reproducible:


Steps to Reproduce:
1. @everything
  
Additional info:
There's no jakarta-commons-io component in Bugzilla so filing against another jakarta-commons component. Please assign to appropriate component.
Comment 2 Alexander Todorov 2009-10-21 08:18:36 EDT
FYI: this is still present in the latest Alpha build
Comment 3 Alexander Todorov 2009-12-08 09:37:19 EST
*** Bug 540429 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Johnston 2010-04-13 18:56:37 EDT
The cat command is being accessed as part of the %update_maven_depmap macro from the %post step.

jakarta-commons-io for RHEL6 Requires jpackage-utils >= 0:1.7.2 for the %post and %postun steps.

jpackage-utils in RHEL6 Requires coreutils which brings in cat.  

This was not true for Fedora 11 jpackage-utils which seems to be the repository you have acquired your packages from.  It was fixed in Fedora 12.  It is correct in the current RHEL6 spec file for jpackage-utils.

Closing this as current release.

Note You need to log in before you can comment on or make changes to this bug.