Bug 507566 - installing links package fails
installing links package fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Dennis Gregorovic
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 06:44 EDT by Alexander Todorov
Modified: 2010-11-11 11:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:27:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-06-23 06:44:20 EDT
Description of problem:

Error(s): Installing links-2.2-9.fc11.x86_64
/var/tmp/rpm-tmp.diwJ2v: line 4: readlink: command not found/var/tmp/rpm-tmp.diwJ2v: line 4: [: =: unary operator expected


readlink is provided by coreutils which is installed after links. 

Also the line

[ $(readlink /etc/alternatives/links) = /usr/bin/links2 ]

in %post and %postun should include quotes since we're comparing strings


Version-Release number of selected component (if applicable):
links-2.2-9.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. install @everyting

Additional info:
no component links in bugzilla so filing against distribution
Comment 2 Bill Nottingham 2009-06-23 12:17:34 EDT
Moving to releng. We probably shouldn't be including links - we already have elinks in the tree.
Comment 3 Dennis Gregorovic 2009-06-23 13:31:06 EDT
links dropped and will not be included in the next compose.
Comment 4 Marian Ganisin 2009-11-13 05:33:26 EST
Compose RHEL6.0-20091111.0 contains links.
Comment 6 Bill Nottingham 2009-12-16 17:05:19 EST
Please retest with alpha3, or beta.
Comment 7 Dennis Gregorovic 2010-02-04 21:51:46 EST
No links package in RHEL6.0-20100203.3
Comment 8 Alexander Todorov 2010-02-05 04:09:22 EST
$ cd /mnt/redhat/rel-eng/RHEL6.0-20100203.3/6
$ find -name "links*"

Moving to VERIFIED.
Comment 9 releng-rhel@redhat.com 2010-11-11 11:27:17 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.