Bug 50758 - ifup ppp0 on a machine with a previously existing default route deletes that route and does not replace it when done.
ifup ppp0 on a machine with a previously existing default route deletes that ...
Status: CLOSED DUPLICATE of bug 48994
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 17:03 EDT by Panic
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 17:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-08-02 17:03:59 EDT
Description of Problem:

This is the same bug as bug# 48994, still present in beta 3.  Essentially,
on a machine with a previously existing default route assigned by DHCP, a
dial-out with DEFROUTE=yes works fine -- except that it deletes the
existing default route and does not put it back when its done, rendering
the other interface pretty much useless when the call is over.

How Reproducible:

Always

Steps to Reproduce:
1. get machine with previously existing DHCP-delivered default route
2. dial out with DEFROUTE=yes set, then ifdown that interface
3. run route -n and notice that the previously existing default route is
gone, and must be added back in by hand (or the interface has to be
restarted, which is easier).

Actual Results:

default route for network interface is deleted and not replaced.

Expected Results:

default route for the network interface should be replaced.

Additional Information:
Comment 1 Glen Foster 2001-08-06 16:48:39 EDT
This really *is* an initscripts problem.

*** This bug has been marked as a duplicate of 48994 ***

Note You need to log in before you can comment on or make changes to this bug.