Bug 507583 - [RHEL-5] Booting problem after OS installation on 2nd raid volume.
[RHEL-5] Booting problem after OS installation on 2nd raid volume.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
All Linux
low Severity medium
: alpha
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 07:40 EDT by Krzysztof Wojcik
Modified: 2011-06-29 10:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 15:40:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs from installation. (65.87 KB, application/x-compressed)
2009-06-23 07:40 EDT, Krzysztof Wojcik
no flags Details

  None (edit)
Description Krzysztof Wojcik 2009-06-23 07:40:38 EDT
Created attachment 349079 [details]
Logs from installation.

Description of problem:

Steps to reproduce:
1. Create two volumes in OROM on same set of HDDs (i.e. 1st RAID1 (50GB) 2nd RAID1 [rest of capacity])
2. Clear MBR sectors of both volumes (i.e. using dd if=/dev/zero of=/dev/mapper/volume_name bs=512 count=1)
3. Write md5sum of this 512 bytes sectors of first volume (i.e. dd if=/dev/mapper/volume_name of=tmp bs=512 count=1; md5sum tmp)
4. Install Red Hat Enterprise Linux 5.4 alpha on second volume.
5. Verify that OS will not boot from 2nd volume
6. Verify that md5sum of first 512 bytes of first was changed

Expected results:
There should be no changes on MBR of first volume. OS should correctly boot from 2nd volume.

Actual results:
Booting process hang up when bootloader should be run. First 512 bytes sector on first volume is changed.

See attached files.
Comment 1 Hans de Goede 2010-08-12 15:40:56 EDT
I've been unable to reproduce this bug. If you can still reproduce this bug with RHEL-5.5 please re-open this bug report.

Note You need to log in before you can comment on or make changes to this bug.