Bug 507588 - possible scriptlet failure for nut-client and nut-cgi
possible scriptlet failure for nut-client and nut-cgi
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Michal Hlavinka
Daniel Riek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 07:56 EDT by Alexander Todorov
Modified: 2009-10-13 12:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 12:15:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-06-23 07:56:22 EDT
Description of problem:
Error(s): Installing nut-client-2.4.1-3.fc11.x86_64
warning: group nut does not exist - using rootwarning: group nut does not exist - using rootwarning: user nut does not exist - using rootwarning: group nut does not exist - using rootwarning: user nut does not exist - using rootwarning: group nut does not exist - using root

Error(s): Installing nut-cgi-2.4.1-3.fc11.x86_64
warning: user nut does not exist - using root

Both packages have:
preinstall scriptlet (using /bin/sh):
/usr/sbin/useradd -c "Network UPS Tools" -u 57 -G dialout \
        -s /bin/false -r -d /var/lib/ups nut 2> /dev/null || :

and a dependency on /usr/sbin/useradd and are installed after shadow-utils which provides useradd.

Version-Release number of selected component (if applicable):
nut-client-2.4.1-3.fc11.x86_64
nut-cgi-2.4.1-3.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. @everything install
2.
3.
  
Actual results:


Expected results:


Additional info:
No component nut in Bugzilla, so filing against distribution.
Comment 2 Michal Hlavinka 2009-06-24 10:17:43 EDT
is it possible to have /etc/passwd and /etc/groups from that machine? If useradd faild it's probably because something was already using uid 57.
Comment 7 Denise Dumas 2009-10-13 12:15:31 EDT
Nut is no longer planned for RHEL6 so closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.