Bug 507609 - %pre scriptlet fails for xguest
%pre scriptlet fails for xguest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xguest (Show other bugs)
6.0
All Linux
high Severity high
: beta
: ---
Assigned To: Daniel Walsh
Milos Malik
:
: 530528 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 09:26 EDT by Alexander Todorov
Modified: 2010-07-02 16:54 EDT (History)
9 users (show)

See Also:
Fixed In Version: xguest-1.0.8-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -ivvvh -p xguest-1.0.8-3.el6.noarch.rpm (5.22 KB, text/plain)
2010-03-02 05:48 EST, Jan Stodola
no flags Details

  None (edit)
Description Alexander Todorov 2009-06-23 09:26:12 EDT
Description of problem:
Error(s): Installing xguest-1.0.7-3.fc11.noarch
/usr/sbin/semanage: No such file or directoryerror: 
%pre(xguest-1.0.7-3.fc11.noarch) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping xguest-1.0.7-3.fc11


Version-Release number of selected component (if applicable):
xguest-1.0.7-3.fc11.noarch

How reproducible:


Steps to Reproduce:
1. @everything installation
2.
3.
  
Actual results:


Expected results:


Additional info:
No xguest component in Bugzilla so filing against distribution
Comment 2 Daniel Walsh 2009-06-24 07:44:39 EDT
Fixed in xguest-1.0.7-5.fc12
Comment 3 releng-rhel@redhat.com 2009-10-28 11:51:05 EDT
Fixed in 'xguest-1.0.7-5.fc12'. 'xguest-1.0.7-6.el6' included in compose 'RHEL6.0-20091027.3'.
Moving to ON_QA.
Comment 5 Daniel Walsh 2009-11-11 10:02:21 EST
I am currently looking at xguest-1.0.7-7.fc12  

# grep pre.*policycoreutils xguest.spec
Requires(pre): policycoreutils-sandbox

rpm -q --requires xguest
/bin/sh  
/bin/sh  
/bin/sh  
config(xguest) = 1.0.7-7.fc12
gdm >= 1:2.20.0-15.fc8
pam >= 0.99.8.1-17
policycoreutils-sandbox  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
sabayon-apply  
selinux-policy > 3.6.3-12
selinux-policy-base  
rpmlib(PayloadIsXz) <= 5.2-1


rpm -q --requires policycoreutils-sandbox
/bin/bash  
/bin/sh  
/bin/sh  
/sbin/chkconfig  
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
libcap-ng.so.0()(64bit)  
libselinux.so.1()(64bit)  
matchbox-window-manager  
policycoreutils-python = 2.0.74-16.fc12
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
xorg-x11-server-Xephyr  
rpmlib(PayloadIsXz) <= 5.2-1

rpm -qf /usr/sbin/semanage
policycoreutils-python-2.0.74-16.fc12.x86_64
Comment 6 Alexander Todorov 2009-12-09 13:03:10 EST
*** Bug 530528 has been marked as a duplicate of this bug. ***
Comment 7 releng-rhel@redhat.com 2009-12-16 16:50:11 EST
Fixed in 'xguest-1.0.7-7.fc12'. 'xguest-1.0.8-1.el6' included in compose 'RHEL6.0-20091216.nightly'.
Moving to ON_QA.
Comment 8 Miroslav Vadkerti 2010-02-09 17:08:21 EST
Still failing in %post sriptlet in compose RHEL6.0-20100209.1:

Red Hat Enterprise Linux release 6.0 Beta (Santiago)
xguest-1.0.8-1.el6.noarch

Installing: xguest-.0.8-1.el6.noarch                                                              14/14 
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot import name userdb
Non-fatal POSTIN scriptlet failure in rpm package xguest-1.0.8-1.el6.noarch
warning: %post(xguest-1.0.8-1.el6.noarch) scriptlet failed, exit status 1

Installed:
  xguest.noarch 0:1.0.8-1.el6                                    

Flipping to assigned
Comment 9 Daniel Walsh 2010-02-10 13:33:50 EST
Fixed in xguest-1.0.8-3.rhel6
Comment 11 Jan Stodola 2010-03-02 05:48:18 EST
Created attachment 397295 [details]
rpm -ivvvh -p xguest-1.0.8-3.el6.noarch.rpm

Moving back to ASSIGNED, I see this bug when testing @everything install using RHEL6.0-20100226.5 build (s390x arch) with xguest-1.0.8-3.el6.noarch.rpm and policycoreutils-python-2.0.78-11.el6.s390x.

install.log:
...
Installing SDL-devel-1.2.13-11.el6.s390x
Installing xguest-1.0.8-3.el6.noarch
/usr/sbin/semanage: No such file or directory
error: %pre(xguest-1.0.8-3.el6.noarch) scriptlet failed, exit status 1

Manual installation in chroot also failed, see attachment.

This is what I get when running semanage manually:
sh-4.1# which semanage 
/usr/sbin/semanage
sh-4.1# semanage user -a -S targeted -P xguest -R xguest_r xguest_u
sh-4.1# semanage boolean -m -S targeted -F /dev/stdin
/usr/sbin/semanage: No such file or directory
Comment 13 Daniel Walsh 2010-03-02 09:15:25 EST
I am not sure why this is not working.

xguest(pre) requires polycoreutils-sandbox Which requires policycoreutils-python which includes semanage?

Bill do you have any idea?
Comment 14 Marian Ganisin 2010-03-02 09:54:26 EST
File /dev/stdin doesn't exist (in installation environment), this seems to be the cause:

# semanage boolean -m -S targeted -F /dev/stdin
/usr/sbin/semanage: No such file or directory
# touch dummy-file
# semanage boolean -m -S targeted -F dummy-file
# semanage boolean -m -S targeted -F fake-file
/usr/sbin/semanage: No such file or directory
# ls /dev/stdin fake-file dummy-file
ls: cannot access /dev/stdin: No such file or directory
ls: cannot access fake-file: No such file or directory
dummy-file
Comment 15 Daniel Walsh 2010-03-02 10:24:17 EST
Thanks, I was totally reading this wrong...

If I change this to /proc/self/0, will it work?  Does this file exist?
Comment 16 Daniel Walsh 2010-03-02 10:42:16 EST
I guess the bug might be, why doesn't /dev/stdin exist?
Comment 17 Daniel Walsh 2010-03-02 10:49:52 EST
Fixed in xguest-1.0.8-4.el6

Although this might be covering up a different bug.
Comment 18 Bill Nottingham 2010-03-02 13:02:48 EST
/dev/stdin is created by the start_udev wrapper script; udev is started without the wrapper by the installer.
Comment 23 Miroslav Vadkerti 2010-03-10 08:44:06 EST
This still fails in xguest-1.0.8-4.rhel6 (dependecy missed?):

xguest-1.0.8-4.el6.noarch.rpm                                                                         |  38 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package xguest-1.0.8-4.el6.noarch
/usr/sbin/semanage: No such file or directory
error: %pre(xguest-1.0.8-4.el6.noarch) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping xguest-1.0.8-4.el6

Failed:
  xguest.noarch 0:1.0.8-4.el6                                                                                                
Complete!
Comment 24 Miroslav Vadkerti 2010-03-10 08:46:39 EST
semanage is a part of policycoreutils-python
Comment 25 Daniel Walsh 2010-03-10 10:08:27 EST
semanage is putting out a bogus error message that leads you to think the semanage package is not installed.

It is complaining about /proc/self/0  Which should have been /proc/self/fd/0
Fixed in xguest-1.0.8-5.el6
Comment 29 releng-rhel@redhat.com 2010-07-02 16:54:24 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.