Bug 507610 - DeprecationWarning: the {sha|md5} module is deprecated; use the hashlib module instead
DeprecationWarning: the {sha|md5} module is deprecated; use the hashlib modul...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-twisted-core (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Dave Malcolm
qe-baseos-daemons
:
: 541648 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 09:35 EDT by Alexander Todorov
Modified: 2010-11-10 16:23 EST (History)
10 users (show)

See Also:
Fixed In Version: python-twisted-core-8.2.0-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 497783
Environment:
Last Closed: 2010-11-10 16:23:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-06-23 09:35:36 EDT
+++ This bug was initially created as a clone of Bug #497783 +++

Description of problem:

while installing via yum:

  Installing     : python-twisted-core                                                                                                                                                                                     10/15 
/usr/lib64/python2.6/site-packages/twisted/python/filepath.py:12: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
/usr/lib64/python2.6/site-packages/twisted/persisted/sob.py:12: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import os, md5, sys
  Installing     : python-twisted-web                                                                                                                                                                                      11/15 
/usr/lib64/python2.6/site-packages/twisted/python/filepath.py:12: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
/usr/lib64/python2.6/site-packages/twisted/persisted/sob.py:12: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import os, md5, sys


Version-Release number of selected component (if applicable):

python-twisted-core.x86_64 0:8.2.0-2.fc11
python-twisted-web.x86_64 0:8.2.0-2.fc11

How reproducible:

always

Actual results:

Deprecation warning.

Expected results:

No deprecation warning.

Additional info:

This is due to python2.6.

--- Additional comment from fedora-triage-list@redhat.com on 2009-06-09 10:38:15 EDT ---


This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 1 Alexander Todorov 2009-06-23 09:36:50 EDT
Filing against RHEl6. Affected packages are:
python-twisted-core-8.2.0-2.fc11.x86_64
python-twisted-names-8.2.0-2.fc11.x86_64
python-twisted-mail-8.2.0-2.fc11.x86_64
python-twisted-news-8.2.0-2.fc11.x86_64
python-twisted-conch-8.2.0-2.fc11.x86_64
python-twisted-web-8.2.0-2.fc11.x86_64
python-twisted-words-8.2.0-2.fc11.x86_64
python-twisted-lore-8.2.0-2.fc11.x86_64


None of them is a component in Bugzilla so filing against distribution. 

Either fix the imports in Python or at least silence the warnings so we have clean install.log
Comment 3 Bill Nottingham 2009-06-23 12:58:00 EDT
Moving to beta target.
Comment 4 Dave Malcolm 2009-10-16 13:43:40 EDT
Reassigning component from "python" to "python-twisted-core"

Looks like 
  /usr/lib[64]/python2.6/site-packages/twisted/python/filepath.py
  /usr/lib[64]/python2.6/site-packages/twisted/persisted/sob.py

should be ported from using sha and md5 and to use hashlib instead.

Seems to have been partially fixed in Fedora since this bug was filed (see bug 497783).
Comment 5 Michal Nowak 2009-11-26 10:56:59 EST
*** Bug 541648 has been marked as a duplicate of this bug. ***
Comment 6 Gianluca Sforna 2010-04-06 18:32:47 EDT
So RHEL 6 is going to include twisted? 
I hope you are in time for pushing version 10.0 (see bug 572372) before you commit to maintain version 8.2 for 7+ years...
Comment 10 Michal Nowak 2010-06-02 05:25:24 EDT
(Not saying I am signing in to test this but) I remember I saw those warnings when running Rhythmbox in terminal with all plugins installed and enabled.
Comment 13 releng-rhel@redhat.com 2010-11-10 16:23:42 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.