Bug 507618 - cpufreq_selector generates AVC's on cpu 1
cpufreq_selector generates AVC's on cpu 1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 09:58 EDT by S.A. Hartsuiker
Modified: 2009-07-20 07:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 07:35:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description S.A. Hartsuiker 2009-06-23 09:58:02 EDT
Description of problem:
Since the last update of selinux-poliy-targeted (now running selinux-policy-targeted-3.6.12-50) cpufreq_selector generates AVC's when setting the frequency to anything other than the default ondemand.
The processor is an Intel dualcore

Version-Release number of selected component (if applicable):
3.6.12-50

How reproducible:
Select any speed other than ondemand from the cpu speeds available

Steps to Reproduce:
1.
2.
3.
  
Actual results:
type=AVC msg=audit(1245765229.102:93): avc:  denied  { read } for  pid=5238 comm="cpufreq-selecto" name="mls" dev=selinuxfs ino=12 scontext=system_u:system_r:cpufreqselector_t:s0-s0:c0.c1023 tcontext=system_u:object_r:security_t:s0 tclass=file
type=AVC msg=audit(1245765229.102:93): avc:  denied  { open } for  pid=5238 comm="cpufreq-selecto" name="mls" dev=selinuxfs ino=12 scontext=system_u:system_r:cpufreqselector_t:s0-s0:c0.c1023 tcontext=system_u:object_r:security_t:s0 tclass=file

Expected results:
no AVC's

Additional info:
Why is it saying something about mls, when I'm running targeted?
Comment 1 Daniel Walsh 2009-06-23 16:57:24 EDT
You can add these rules now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.6.12-57.fc11
Comment 2 S.A. Hartsuiker 2009-07-20 07:35:19 EDT
Works for me. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.