Bug 507647 - Can't actually exit firstboot after configuring kdump
Can't actually exit firstboot after configuring kdump
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity high
: alpha
: ---
Assigned To: Neil Horman
:
: 507777 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 11:57 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
4 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.0-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 08:13:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2009-06-23 11:57:57 EDT
Description of problem:
Walking through firstboot-1.106-1 with kexec-tools-2.0.0-14.el6, I can configure kdump but when clicking "Finish" I end up in a continuous loop talking about needing to rebooting, acknowledging and then clicking "Finish" and getting the warning about reboot again.

Version-Release number of selected component (if applicable):
firstboot-1.106-1
kexec-tools-2.0.0-14.el6

How reproducible:
Always

Steps to Reproduce:
1. Run firstboot
2. Walk through and choose to enable kdump

Actual results:
Continuous loop

Expected results:
Firstboot actually completes
Comment 1 Neil Horman 2009-06-23 12:17:30 EDT
Those buttons are controlled by the firstboot infrastructure.  I think the firstboot owner is going to have to take a look at this first.
Comment 2 Bill Nottingham 2009-06-23 13:13:02 EDT
The module needs to return proper success/error code. The apply() method currently always returns failure.
Comment 3 Neil Horman 2009-06-23 14:03:56 EDT
Very well, thanks.

fixed in 2.0.0-15.el6
Comment 4 Jay Turner 2009-06-24 07:20:21 EDT
Looks like we're heading in the right direction.  I did the following:

1) Installed 2.0.0-15.el6.x86_64
2) Ran firstboot
3) Chose to enable firstboot, accepting the defaults
4) Clicked "Yes" to the message about needing to reboot in order for changes to take effect

firstboot CRITICAL: Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/firstboot/interface.py", line 102, in _nextClicked
    self.advance()
  File "/usr/lib64/python2.6/site-packages/firstboot/interface.py", line 165, in advance
    self.checkReboot()
  File "/usr/lib64/python2.6/site-packages/firstboot/interface.py", line 177, in checkReboot
    if module.needsReboot():
TypeError: 'bool' object is not callable
Comment 5 Jay Turner 2009-06-24 07:21:51 EDT
I get the same behavior no matter what I select on the kdump configuration screen:

- choose to not enable kdump and click "Finish"
- choose to enable kdump, then click "No" to the question about rebooting
Comment 6 Neil Horman 2009-06-24 10:54:20 EDT
Ok, fixed and verified on test1189.test.redhat.com this time.  Fix available in kexec-tools-2.0.0-16.el6
Comment 7 Neil Horman 2009-06-24 11:02:01 EDT
*** Bug 507777 has been marked as a duplicate of this bug. ***
Comment 8 Jay Turner 2009-06-24 15:30:09 EDT
I got this once with kexec-tools-2.0.0-16.el6.  Trying to figure out how that happened:

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/firstboot/interface.py", line 274, in createScreens
    module.createScreen()
  File "/usr/share/firstboot/modules/firstboot_kdump.py", line 158, in createScreen
    self.initialState = self.kdumpEnabled
AttributeError: moduleClass instance has no attribute 'kdumpEnabled'
Comment 9 Jay Turner 2009-06-24 15:35:57 EDT
And I have a root cause.  Will open another BZ to cover but it's a corner case . . . very far corner!

kexec-tools-2.0.0-16.el6 working well otherwise.
Comment 10 Jay Turner 2010-01-20 08:13:52 EST
kexec-tools-2.0.0-48.el6 included in RHEL6.0-20100116.0.

Note You need to log in before you can comment on or make changes to this bug.