This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 507653 - Kdevelop is missing key support items like konsole
Kdevelop is missing key support items like konsole
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdevelop (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 12:21 EDT by Rick L Vinyard Jr
Modified: 2009-09-12 19:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 19:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick L Vinyard Jr 2009-06-23 12:21:17 EDT
Kdevelop version: 3.5.10-11

Kdevelop is missing key support items like the embedded konsole. To get it to work as expected it would need to depend on kdebase3, since kdebase4 doesn't provide the needed support.
Comment 1 Kevin Kofler 2009-06-23 12:59:29 EDT
Well, if you want it, just install kdebase3. It's not strictly required.

But I guess we can put the dependency there, it's not like KDevelop isn't bloated with dependencies anyway.
Comment 2 Rick L Vinyard Jr 2009-06-23 14:49:29 EDT
(In reply to comment #1)
> Well, if you want it, just install kdebase3. It's not strictly required.
> 

True, but I think the counterintuitive (at least to me) thing is the reliance on the now older kdebase3 rather than kdebase4. In F10 I installed the KDE group along with kdevelop and everything was fine. Now, in F11 the KDE group installs kdebase4 and the same combo yields a tweaky kdevelop.

> But I guess we can put the dependency there, it's not like KDevelop isn't
> bloated with dependencies anyway.  

That's why I really wish rpm had 'recommends' and 'suggests' tags like deb does. But, I digress... this isn't the place for such discussions.
Comment 3 Kevin Kofler 2009-06-23 15:48:57 EDT
The default kdebase has been KDE 4 since F9 (and it's no longer called kdebase4, but just kdebase, because it's the default, though kdebase4 is a virtual Provides still provided by kdebase). I guess something you used in F10 dragged in kdebase3 and no longer does in F11.
Comment 4 Kevin Kofler 2009-06-23 15:49:28 EDT
Oh, and I also think soft dependencies are needed. :-)
Comment 5 Rick L Vinyard Jr 2009-06-23 16:08:09 EDT
(In reply to comment #3)
> The default kdebase has been KDE 4 since F9 (and it's no longer called
> kdebase4, but just kdebase, because it's the default, though kdebase4 is a
> virtual Provides still provided by kdebase). I guess something you used in F10
> dragged in kdebase3 and no longer does in F11.  

That is very likely the case. The machine I used with F10 had been upgraded release by release from FC5.

This one is a clean install of F11.
Comment 6 Rick L Vinyard Jr 2009-06-23 16:09:47 EDT
(In reply to comment #4)
> Oh, and I also think soft dependencies are needed. :-)  

Absolutely. I like the way apt-get approached them.
Comment 7 Steven M. Parrish 2009-07-22 09:13:37 EDT
Ping?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Steven M. Parrish 2009-09-12 19:43:22 EDT
Is this still an issue? Especially with a new kdevelop soon to be avail if it is not already.  I'm leaning towards closing this.  Comments Rex, Kevin?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Rex Dieter 2009-09-12 19:54:11 EDT
Sure ok, fixed in rawhide.

* Sat Sep 12 2009 Rex Dieter <rdieter@fedoraproject.org> 9:3.5.4-6
- make -libs unconditional
- Requires: kdebase3 (#507653)

Will be included in any future kdevelop update for prior releases too (this alone probably doesn't justify an update)

Note You need to log in before you can comment on or make changes to this bug.