Bug 507669 - xen guest kickstart fails with Invalid function call error.
xen guest kickstart fails with Invalid function call error.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Partha Aji
Preethi Thomas
: Reopened
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-23 13:32 EDT by Preethi Thomas
Modified: 2009-09-10 15:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:26:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks-profile for guest kickstart (8.75 KB, text/plain)
2009-06-25 09:06 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Preethi Thomas 2009-06-23 13:32:11 EDT
Description of problem:
xen guest kickstart fails with Invalid function call error.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090619.0-i386-embedded-oracle.iso
How reproducible:


Steps to Reproduce:
1.create a xen guest kickstart profile
2.kickstart a xen guest with the above profile
3. rhn_check on the client
  
Actual results:
D: Sending back response (6, 'Invalid function call attempted', {})


Expected results:

xen guest created
Additional info:
D: do_call kickstart_guest.initiate ('rlx-0-10.rhndev.redhat.com', 'rlx-3-24.rhndev.redhat.com:1:pt-guest3', 'xenpv', 4, 'pt-guest3', 524288, 1, 5, 'xenbr0', '/var/lib/xen/pt-guest3', ' ksdevice=eth0  ksdevice=eth0 ')
D: Attempt to call an unsupported action kickstart_guest.initiate ('rlx-0-10.rhndev.redhat.com', 'rlx-3-24.rhndev.redhat.com:1:pt-guest3', 'xenpv', 4, 'pt-guest3', 524288, 1, 5, 'xenbr0', '/var/lib/xen/pt-guest3', ' ksdevice=eth0  ksdevice=eth0 ')
D: Sending back response (6, 'Invalid function call attempted', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
Comment 1 Preethi Thomas 2009-06-25 09:03:24 EDT
client configs
[root@rlx-3-24 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.3 (Tikanga)
[root@rlx-3-24 ~]# rpm -q kernel-xen
kernel-xen-2.6.18-128.el5
kernel-xen-2.6.18-128.1.10.el5
Comment 2 Preethi Thomas 2009-06-25 09:06:46 EDT
Created attachment 349395 [details]
ks-profile for guest kickstart
Comment 3 Steve Salevan 2009-06-25 10:56:29 EDT

*** This bug has been marked as a duplicate of bug 494884 ***
Comment 4 Justin Sherrill 2009-06-25 11:49:53 EDT
re-opening as this looks like a different cause as 494884
Comment 5 Partha Aji 2009-06-25 18:59:39 EDT
Basic issue is that rhn-virtualization-host package did not get installed, because it was not signed and that cause the guest installation to fail. Try it with a signed rhn-virtualization-host and it shoudl work..
Comment 6 Preethi Thomas 2009-07-02 14:54:48 EDT
verified
Satellite-5.3.0-RHEL5-re20090625.0-i386-embedded-oracle.iso
with rhn-virtualization-host installed 
xen-guest kickstarted and without the Invalid function call error.
Comment 7 Steve Salevan 2009-08-06 15:20:29 EDT
RELEASE_PENDING from 7/24 build.
Comment 8 Brandon Perkins 2009-09-10 15:26:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.