Bug 507750 - requires mysql
requires mysql
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: MySQL-python (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 22:44 EDT by Bill Nottingham
Modified: 2014-03-16 23:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.2.3-0.1.c1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 15:53:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-06-23 22:44:55 EDT
Description of problem:

MySQL-python has a hardcoded requirement on mysql, which is just binaries and man pages. Does it actually require that? (As opposed to mysql-libs, which it pulls in anyway.)

Version-Release number of selected component (if applicable):

MySQL-python-1.2.2-10.fc11.i586
Comment 1 Tom Lane 2009-06-25 16:55:15 EDT
That code predates the split of mysql into a base and -libs package.  I think you're probably right that the dependency could be narrowed.  I wonder whether the explicit dependencies on python and mx are needed anymore either --- thoughts?
Comment 2 Bill Nottingham 2009-06-25 17:19:17 EDT
It gets a dep on "python(abi) = 2.6" when built, so I think that's not needed.

mx looks like it's still needed (well, if the python code needs it.)
Comment 3 Tom Lane 2009-06-28 12:51:57 EDT
Actually it looks like the mx dependency is history too, so I removed that one also.
Comment 4 Fedora Update System 2009-06-28 13:00:32 EDT
MySQL-python-1.2.3-0.1.c1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/MySQL-python-1.2.3-0.1.c1.fc11
Comment 5 Fedora Update System 2009-06-30 17:40:59 EDT
MySQL-python-1.2.3-0.1.c1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update MySQL-python'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7166
Comment 6 Fedora Update System 2009-07-03 15:53:43 EDT
MySQL-python-1.2.3-0.1.c1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.