Bug 507770 - Fedora 11 installer changes the keyboard language to Greek when the Greek keyboard layout is selected
Fedora 11 installer changes the keyboard language to Greek when the Greek key...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 02:38 EDT by Panos Kavalagios
Modified: 2010-03-15 02:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 13:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panos Kavalagios 2009-06-24 02:38:35 EDT
Description of problem: If you set during installation that you have a Greek layout keyboard, then the language is set to Greek and you cannot enter a hostname or root password in English. Pressing shifts simultaneously toggles the language to English, but this is something that most of the Greek people are not aware, since we have used to press alt-shift for keyboard language change (blame windows). A "grp:alt_shift_toggle" is more appropriate and even a XkbLayout=us,gr and not XkbLayout=gr,us.


Version-Release number of selected component (if applicable):


How reproducible: Install Fedora 11 DVD either 32bit or 64bit


Steps to Reproduce:
1. Select English as the installation language
2. Set your keyboard layout to Greek
3. Try to enter a hostname on the next screen or root's password
  
Actual results: The hostname is written in Greek. If you leave the default and you proceed to root's password you will get a warning that root's password must contain latin characters.


Expected results: The input language should have remained English for the whole installation process.


Additional info: It is very irritating to have to toggle back to English and for someone that does not know how to do it, it is unable to install Fedora.
Comment 1 Chris Lumens 2009-07-01 13:16:42 EDT
This is expected behavior - if you select a different language, you get that language for the rest of installation.  If you select a different keyboard, you get that keyboard for the rest of installation.
Comment 2 Panos Kavalagios 2009-07-02 01:50:14 EDT
Yes, but if you select English keyboard layout, you won't get any Greek support, as I don't see any explicitly Greek support option later on package selection screen, right?
Comment 3 Nikos Charonitakis 2010-03-11 10:47:11 EST
This problem is still present in fedora 13 alpha.
Crhis this is not the expected behaviour. User selects Greek keyboard in order to be able to type Greek text by switching layouts when the system is up and running.
Instead of that he is left in the cold trying to guess the appropriate keyboard combination for switching layouts in the middle of installation process.
This problem returned again and again many times in the past. Some time before it was fixed but it seems the fix was not permanent.
To summarize: Default layout should be English when a user selects Greek keyboard and we just need a way to switch layouts when user starts using the system.
Switching layouts was served by a gnome panel applet, but in F13 alpha this applet is missing...
Comment 4 Panos Kavalagios 2010-03-15 02:57:22 EDT
Indeed, it works fine on other distributions installers. Only in Fedora it has that weird behaviour. In fact in an installer prompt you will have to provide a Greek text to... let me think... NOWHERE! The same applies to most of the languages since non-latin characters are not allowed to host names for example.

Note You need to log in before you can comment on or make changes to this bug.