Bug 507777 - interface.py backtrace
interface.py backtrace
Status: CLOSED DUPLICATE of bug 507647
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 03:32 EDT by Jens Petersen
Modified: 2009-06-24 11:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 507778 (view as bug list)
Environment:
Last Closed: 2009-06-24 11:02:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initial backtrace (326 bytes, text/plain)
2009-06-24 03:35 EDT, Jens Petersen
no flags Details
later backtrace (423 bytes, text/plain)
2009-06-24 03:35 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2009-06-24 03:32:54 EDT
Description of problem:
Just installed latest rel-eng tree and see a backtrace instead the EULA page.

Version-Release number of selected component (if applicable):
firstboot-1.106-2.el6.x86_64

Steps to Reproduce:
1. boot install
  
Actual results:
greeted with python backtrace dialog

Expected results:
no backtrace

Additional info:
gimme more python backtraces ;)
Comment 1 Jens Petersen 2009-06-24 03:35:17 EDT
Created attachment 349206 [details]
initial backtrace
Comment 2 Jens Petersen 2009-06-24 03:35:49 EDT
Created attachment 349207 [details]
later backtrace
Comment 3 RHEL Product and Program Management 2009-06-24 03:46:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Jens Petersen 2009-06-24 03:52:17 EDT
(In reply to comment #1)
> Created an attachment (id=349206) [details]
> initial backtrace  

Sorry this one is from redhat-release: I filed bug 507778 for it.
Comment 5 Bill Nottingham 2009-06-24 10:45:30 EDT
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/firstboot/interface.py", line 102, in _nextClicked
    self.advance()
  File "/usr/lib64/python2.6/site-packages/firstboot/interface.py", line 164, in advance
    self.checkReboot()
  File "/usr/lib64/python2.6/site-packages/firstboot/interface.py", line 175, in checkReboot
    if module.needsReboot():
TypeError: 'bool' object is not callable

needsReboot in the kdump module is a boolean, not a function.
Comment 6 Neil Horman 2009-06-24 11:02:01 EDT

*** This bug has been marked as a duplicate of bug 507647 ***

Note You need to log in before you can comment on or make changes to this bug.