Bug 507792 - anki does not install, wants old python
anki does not install, wants old python
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anki (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 06:15 EDT by Martin Ellison
Modified: 2009-06-26 00:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 00:04:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my packages still at fc10 (21.36 KB, text/plain)
2009-06-25 04:29 EDT, Martin Ellison
no flags Details

  None (edit)
Description Martin Ellison 2009-06-24 06:15:29 EDT
Description of problem: anki will not install on Fedora 11

Version-Release number of selected component (if applicable):  anki.noarch 0:0.9.9.7.9b

How reproducible: repeatable for me

Steps to Reproduce:
1. yum -y install anki
  
Actual results: fails to install

Expected results: installs and is executable

Additional info: message from yum:
Error: Missing Dependency: python(abi) = 2.5 is needed by package anki-0.9.9.7.9b-1.fc10.noarch (updates)
Comment 1 Martin Ellison 2009-06-24 06:32:22 EDT
I was able to install anki by downloading the rpm from http://download.fedora.redhat.com/pub/fedora/linux/updates/11/i386/; I'm not sure why yum did not pick this up. 

This version gave me some errors like 
ImportError: libssl.so.7: cannot open shared object file: No such file or directory
for which I did
# ln -s libssl.so libssl.so.7
and the same for libcrypto. Now anki at least starts.
Comment 2 Christian Krause 2009-06-24 17:52:53 EDT
Hi Martin,

(In reply to comment #0)
> Description of problem: anki will not install on Fedora 11
[...]
> Additional info: message from yum:
> Error: Missing Dependency: python(abi) = 2.5 is needed by package
> anki-0.9.9.7.9b-1.fc10.noarch (updates)  

If you see this message then yum tries to install an package for Fedora 10 in your F11 system. The correct package for F11 is anki-0.9.9.7.9b-1.fc11.noarch. The F11 package correctly requires python 2.6:

rpm -q --requires anki-0.9.9.7.9b-1.fc11.noarch  |grep python\(abi
python(abi) = 2.6

Probably something is mixed up on your system. 
Have you done a fresh installation or did you upgrade from F10 or rawhide?

Please add the output of the following commands to this bug report:

rpm -q fedora-release
rpm -V fedora-release
cat /etc/fedora-release


(In reply to comment #1)
> I was able to install anki by downloading the rpm from
> http://download.fedora.redhat.com/pub/fedora/linux/updates/11/i386/; I'm not
> sure why yum did not pick this up. 

Please add the output of:

rpm -qi anki 

as well.

> This version gave me some errors like 
> ImportError: libssl.so.7: cannot open shared object file: No such file or
> directory
> for which I did
> # ln -s libssl.so libssl.so.7
> and the same for libcrypto. Now anki at least starts.  

This is very strange. F11 already provides libssl.so.8 and I'm not sure which other library/program could require libssl.so.7 right now. So unfortunately it looks like that your F11 installation is not 100% complete. Please do a quick check with 

rpm -qa | grep fc10
and
rpm -qa | grep fc11

The output of the first command should not reveal any packages (if yes, please attach the output), but the second one should print out all packages you have installed for F11 (output is not needed).


Best regards,
Christian
Comment 3 Martin Ellison 2009-06-25 04:28:17 EDT
Christian,

Lots of fc10 packages, will attach. yum was complaining that they were newer that the fc11 packages that were supposed to replace them.

I upgraded from Fedora 10.

nb I am currently trying a yum -y upgrade (still downloading).

> ls -l /usr/lib/libssl*
lrwxrwxrwx. 1 root root     20 2009-06-24 08:57 /usr/lib/libssl3.so -> ../../lib/libssl3.so
lrwxrwxrwx. 1 root root     16 2009-06-24 09:15 /usr/lib/libssl.so -> libssl.so.0.9.8k
-rwxr-xr-x. 1 root root 311404 2009-03-26 05:20 /usr/lib/libssl.so.0.9.8k
lrwxrwxrwx. 1 root root      9 2009-06-24 18:23 /usr/lib/libssl.so.7 -> libssl.so
lrwxrwxrwx. 1 root root     16 2009-06-24 09:03 /usr/lib/libssl.so.8 -> libssl.so.0.9.8k

Presumably some package called by anki was hardcoded to require libssl.so.7 instead of libssl.so. So I spoofed libssl.so.7 to point at the current version. It seems to have worked.

> rpm -q fedora-release
fedora-release-11-1.noarch
> rpm -V fedora-release
~/git/sunmoonstars> cat /etc/fedora-release
Fedora release 11 (Leonidas)
> rpm -qi anki 
Name        : anki                         Relocations: (not relocatable)
Version     : 0.9.9.7.9b                        Vendor: Fedora Project
Release     : 1.fc11                        Build Date: Tue 26 May 2009 02:58:18 HKT
Install Date: Wed 24 Jun 2009 18:21:20 HKT      Build Host: xenbuilder2.fedora.redhat.com
Group       : Amusements/Games              Source RPM: anki-0.9.9.7.9b-1.fc11.src.rpm
Size        : 4974501                          License: GPLv3+ and MIT
Signature   : RSA/8, Fri 29 May 2009 20:36:04 HKT, Key ID 1dc5c758d22e77f2
Packager    : Fedora Project
URL         : http://www.ichi2.net/anki
Summary     : Flashcard program for using space repetition learning
Description :
Anki is a program designed to help you remember facts (such as words
and phrases in a foreign language) as easily, quickly and efficiently
as possible. Anki is based on a theory called spaced repetition.

Martin
Comment 4 Martin Ellison 2009-06-25 04:29:44 EDT
Created attachment 349356 [details]
my packages still at fc10

for Christian as requested.
Comment 5 Christian Krause 2009-06-25 17:51:44 EDT
Martin,

(In reply to comment #3)
> Lots of fc10 packages, will attach. yum was complaining that they were newer
> that the fc11 packages that were supposed to replace them.

I've looked at the attached list and these are too many packages with fc10 in the name. Sure, there are a couple of packages in the F11 repository (ls fedora/11/i386/os/Packages/*fc10*), but not that many.

> I upgraded from Fedora 10.
> nb I am currently trying a yum -y upgrade (still downloading).

Yes, it looks like that your system is right now in a state between F10 and F11 - some packages still F10, some are F11. I'm sure it is necessary to fix this in order to get all dependencies correctly resolved.

You can also install yum-utils and use:

package-cleanup --orphans

If the yum repo files are correct, this program will tell you which packages are still from the F10 repository.

> Presumably some package called by anki was hardcoded to require libssl.so.7
> instead of libssl.so. So I spoofed libssl.so.7 to point at the current version.
> It seems to have worked.

Yeah, maybe. One of anki's dependencies seems to have a dependency to the ssl library. But until your system is in a defined status (only F11 packages, all F11 updates installed) I doubt that it would make sense to search for the problem.

> > rpm -qi anki 
> Name        : anki                         Relocations: (not relocatable)
> Version     : 0.9.9.7.9b                        Vendor: Fedora Project
> Release     : 1.fc11                        Build Date: Tue 26 May 2009

Yes, that's the correct anki package. Please try to cleanup your system and then try to install anki again.

Please let me know whether you have then still any problems.

Christian
Comment 6 Martin Ellison 2009-06-26 00:04:44 EDT
Probably the moral is to do a yum update (or the equivalent) after a DVD upgrade, and only then expect things to work. The problem seems to be that the fc10 packages on my system were newer than the corresponding packages on the F11 release DVD, so anaconda did not install the F11 versions, and neither would yum when I tried to specifically upgrade them. And many of the old packages required Python 2.5 which was not there any more. A blanket "yum -y upgrade --skip-broken" seems to have worked though. 

Anyway, it seems to be a general problem with Fedora upgrades, and not anki-specific, so I have closed the ticket.

Note You need to log in before you can comment on or make changes to this bug.