Bug 507889 - twinkle: cannot access the speaker (alsa: default)
twinkle: cannot access the speaker (alsa: default)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: twinkle (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 12:05 EDT by Amit Shah
Modified: 2009-06-28 20:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 20:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
twinkle.log (2.13 KB, text/plain)
2009-06-24 14:26 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2009-06-24 12:05:49 EDT
Description of problem:
Using twinkle on F11 with a KDE install. I have pulseaudio enabled, and the default output server. I'm using it with the xine backend.

twinkle on startup gives:

cannot access the ring tone device (alsa: default)
cannot access the speaker (alsa: default)
cannot access the microphone (alsa: default)

I've used twinkle on the same setup a few times earlier and it worked fine. I had removed pulseaudio in between, tried it, and twinkle worked fine. I installed it again, and twinkle had worked. All this w/o a system reboot or login/logout from the kde session.

And suddenly it stopped working with the error given above.
Comment 1 Kevin Fenzi 2009-06-24 14:10:02 EDT
Odd indeed. There were no changes at all between it working and not working?
no package updates? login/logouts? pulseaudio restarts?

Can you attach your ~/.twinkle/twinkle.log file from a failed start?

Is pulseaudio running?
Comment 2 Amit Shah 2009-06-24 14:25:59 EDT
So yesterday I installed pulseaudio and tried twinkle, it worked. But it wasn't using pulseaudio at the time (because the xine backend didn't have the pulse plugin).

Jun 23 19:31:14 Installed: pulseaudio-0.9.15-14.fc11.x86_64

That was yesterday and twinkle was working.

Today, I had installed these apps:

Jun 24 11:54:37 Installed: wxBase-2.8.10-1.fc11.x86_64
Jun 24 11:54:39 Installed: wxGTK-2.8.10-1.fc11.x86_64
Jun 24 11:54:39 Installed: vamp-plugin-sdk-2.0-5.fc11.x86_64
Jun 24 11:54:40 Installed: soundtouch-1.4.0-2.fc11.x86_64
Jun 24 11:54:40 Installed: libid3tag-0.15.1b-8.fc11.x86_64
Jun 24 11:54:45 Installed: audacity-1.3.7-0.7.beta.fc11.x86_64
Jun 24 19:46:36 Installed: xine-lib-pulseaudio-1.1.16.3-2.fc11.x86_64

After this, twinkle audio wasn't working. I installed the xine plugin for pulseaudio because I realised I wasn't running pulseaudio at all. Even after this, twinkle audio hasn't been working.

Between all this, there were no logout/logins or pulseaudio restarts.

I did switch to pulseaudio in my systemsettings after installing the xine plugin and kde sounds do go via pulseaudio. twinkle doesn't seem to (I have logged out/logged in multiple times to confirm).

Attaching the twinkle.log file with the relevant info from startup (had to trim because it had some auth info)
Comment 3 Amit Shah 2009-06-24 14:26:46 EDT
Created attachment 349292 [details]
twinkle.log
Comment 4 Amit Shah 2009-06-25 12:14:38 EDT
After a few other updates (kde 4.2.4, etc) I rebooted the system and twinkle audio works fine. Though it'll be interesting to get to the root of that problem
Comment 5 Kevin Fenzi 2009-06-28 15:09:28 EDT
Yeah, all I can think of is that something weird was going on in the xine-lib-pulseaudio plugin? Or something odd with your login where you didn't get the audo device acls correctly? 

I'm not sure what else to do here... should we just close this bug for now and reopen or file a new one if it appears again?
Comment 6 Amit Shah 2009-06-28 20:31:03 EDT
Yeah, I guess we can close it now. I'll report a new one if it happens again. Thanks.

Note You need to log in before you can comment on or make changes to this bug.