Bug 507900 - Printing to Lexmark E232 Not Working
Printing to Lexmark E232 Not Working
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 12:34 EDT by Garry Reisky
Modified: 2009-07-11 18:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 18:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lpinfo (2.81 KB, text/plain)
2009-06-24 12:35 EDT, Garry Reisky
no flags Details
lsusb (432 bytes, text/plain)
2009-06-24 12:35 EDT, Garry Reisky
no flags Details
troubleshoot (49.95 KB, text/plain)
2009-06-24 23:25 EDT, Garry Reisky
no flags Details
lpinfo2 (594 bytes, text/plain)
2009-06-25 11:17 EDT, Garry Reisky
no flags Details
error_log (316 bytes, text/plain)
2009-07-06 13:36 EDT, Garry Reisky
no flags Details

  None (edit)
Description Garry Reisky 2009-06-24 12:34:30 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce: 
1.  Print a text file or test page
2.  Under Printer Configuration , Try to change device uri "There was an error during the CUPS operation 'client-error-forbidden'."
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Garry Reisky 2009-06-24 12:35:30 EDT
Created attachment 349272 [details]
lpinfo
Comment 2 Garry Reisky 2009-06-24 12:35:59 EDT
Created attachment 349274 [details]
lsusb
Comment 3 Tim Waugh 2009-06-24 17:40:53 EDT
Please update to the most recent system-config-printer and CUPS test updates:

yum --enablerepo=updates-testing update 'system-config-printer*' 'cups*'

Then run the printing troubleshooter: System->Administration->Printing, then Help->Troubleshoot.  Please attach the resulting troubleshoot.txt file to this bug report.
Comment 4 Garry Reisky 2009-06-24 23:25:13 EDT
Created attachment 349326 [details]
troubleshoot
Comment 5 Garry Reisky 2009-06-24 23:27:11 EDT
I updated cups from updates-testing. Right after that I ran printer troubleshooting.
Comment 6 Tim Waugh 2009-06-25 04:12:35 EDT
Please show me the output of this command, as root, making sure the printer is connected and turned on first:

/usr/sbin/lpinfo -l --include-schemes=usb -v
Comment 7 Garry Reisky 2009-06-25 11:17:12 EDT
Created attachment 349413 [details]
lpinfo2
Comment 8 Tim Waugh 2009-06-25 11:42:30 EDT
OK, the device URI is incorrect, and this is due to bug #507244.

On to the next problem:
(In reply to comment #0)
> 2.  Under Printer Configuration , Try to change device uri "There was an error
> during the CUPS operation 'client-error-forbidden'."

Are you running system-config-printer as root, or as a normal (non-root) user?  There is a known problem with running PolicyKit-enabled applications as root: bug #447266.

Can you change the device URI if you run system-config-printer as a normal (non-root) user?
Comment 9 Garry Reisky 2009-06-25 23:13:34 EDT
> Can you change the device URI if you run system-config-printer as a normal
> (non-root) user?  

No. It keeps prompting for a root pass to make changes to the device URI
Comment 10 Tim Waugh 2009-06-26 04:33:18 EDT
Just to clarify: are you entering the root password into the dialog and that fails somehow?
Comment 11 Garry Reisky 2009-07-04 13:11:23 EDT
The root password doesn't fail. Trying to change teh device URI does
Comment 12 Tim Waugh 2009-07-06 09:19:40 EDT
Please do the following, as root:

/sbin/service cups restartlog

Then, attempt to change the device URI using system-config-printer as a non-root user.  When that fails, please attach the file /var/log/cups/error_log to this bug report.  Thanks.
Comment 13 Garry Reisky 2009-07-06 13:36:51 EDT
Created attachment 350649 [details]
error_log
Comment 14 Garry Reisky 2009-07-06 13:40:25 EDT
I was in system-config-printer and I changed the Device URI. When prompted for the root password I entered it than I chose under devices. "Lexmark International Lexmark E232" . I applied these settings and printed a test page and it worked. Also. I updated cups from updates-testing about 2 or 3 days ago. I am running cups-1.4-0.rc1.7.fc11.i586
Comment 15 Jiri Popelka 2009-07-07 12:35:35 EDT
Found similar problem description and error_log

http://forums.fedoraforum.org/showthread.php?t=224132
Comment 16 Tim Waugh 2009-07-10 13:44:47 EDT
So is it all working now, with the newer cups package?
Comment 17 Garry Reisky 2009-07-11 13:38:59 EDT
Yes it is working.

Note You need to log in before you can comment on or make changes to this bug.