Bug 507928 - kpackage stalls
kpackage stalls
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdeadmin (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 14:35 EDT by Herbert Carl Meyer
Modified: 2009-06-28 20:04 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 20:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 182513 None None None Never

  None (edit)
Description Herbert Carl Meyer 2009-06-24 14:35:58 EDT
Description of problem:

kpackage stalls, displaying message: "Querying installed package list", never finishes to display package tree. Top shows it quietly consuming 2-4% cpu.

Version-Release number of selected component (if applicable):
4.2.3-1.fc11

How reproducible:
100%

Steps to Reproduce:
1. install kdeadmin-kpackage
2. start kpackage
3. wait
  
Actual results:
wait forever

Expected results:
kpackage displays installed packages

Additional info:
I am trying to use kpackage because it can install .deb's. I want to avoid fooling around with alien.
Comment 1 Rex Dieter 2009-06-24 15:00:13 EDT
forever = how long exactly?

I ask, because it's smart-based, and it reportedly takes a *long* time to setup initially.
Comment 2 Herbert Carl Meyer 2009-06-24 15:55:55 EDT
Hi Rex: forever ~= 20 - 25 min, in two tries. One at 1am last night. I will repeat when I am not watching or tying to stay awake.
Comment 3 Kevin Kofler 2009-06-25 00:17:17 EDT
> I am trying to use kpackage because it can install .deb's. I want to avoid
> fooling around with alien.

From http://labix.org/smart (which is what KPackage is based on):
> Notice that this project is *not* a magical bridge between every distribution
> in the planet. Instead, this is software offering *better package management*
> for these distributions when working with *their native packages*. Using
> multiple packaging systems at the same time (like rpm and dpkg) *is possible*
> but would require packages from those systems to follow the same packaging
> guidelines. As this is not the case at the moment, mixing package systems is
> *not* recommended.

Smart/KPackage are not magical tools to support installing .deb packages on RPM-based distributions.
Comment 4 Herbert Carl Meyer 2009-06-25 00:20:25 EDT
tonight forever > 1 1/2 hr. Tomorrow I will try smart-gui to see if smart is working by itself. I may have used smart some time ago (apt-get related ? on suse ?), but don't remember it well enough to use it bare.
Comment 5 Herbert Carl Meyer 2009-06-25 00:25:48 EDT
Thank you kevin, I am aware that kpackage is not a magic bullet. I will compile the real target package from source.
However, the bug report is still valid, kpackage is not working properly.
Comment 6 Herbert Carl Meyer 2009-06-25 00:50:39 EDT
After installing smart-gui, running it, replying to prompts and connecting channels, doing a refresh, smart shows the available updates.
Quitting smart-gui, and starting kpackage, after about 90 secs, kpackage shows the available updates.
I think that kpackage cannot kickstart smart, and will not work until smart is configured.
Comment 7 Steven M. Parrish 2009-06-28 16:47:45 EDT
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Herbert Carl Meyer 2009-06-28 19:45:07 EDT
I have added this to kde bug 192512, started on Jan 31, 2009 on a debian system. Looks like the same problem. The kde bug is assigned to Toivo Pedaste.
Comment 9 Herbert Carl Meyer 2009-06-28 19:53:37 EDT
opps, kde bug number ia 182513.
Comment 10 Steven M. Parrish 2009-06-28 20:04:48 EDT
Thanks for the update will monitor upstream for a resolution

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.