Bug 507934 - Fresh install of Fedora 11 x86_64 on MacPro server cannot find Intel 10f6 network card.
Fresh install of Fedora 11 x86_64 on MacPro server cannot find Intel 10f6 net...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 14:58 EDT by Nick Boldt
Modified: 2009-11-11 20:34 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-11 20:34:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (5.02 KB, text/plain)
2009-06-24 14:58 EDT, Nick Boldt
no flags Details
lspci -nn output (6.14 KB, text/plain)
2009-06-28 00:59 EDT, Nick Boldt
no flags Details
/var/log/messages after startup (957.59 KB, text/plain)
2009-06-28 01:00 EDT, Nick Boldt
no flags Details

  None (edit)
Description Nick Boldt 2009-06-24 14:58:07 EDT
Created attachment 349296 [details]
lspci output

Description of problem:

Fresh install of Fedora 11 x86_64 on MacPro server cannot find network card.

Version-Release number of selected component (if applicable):

Fedora 11 x86_64 install DVD

How reproducible:

Steps to Reproduce:
1. Buy this: http://www.cdw.ca/shop/products/default.aspx?EDC=1698818
2. Install 2x1G extra RAM in recommended slots (total 8x1G RAM)
3. Install 3x640G extra drives in SATA bays 2-4.
  
Actual results:

Installs OK, but no network found. Tried manually setting things and rebooting a few times, but never got anything more than loopback device.

Expected results:

"Just Works" networking support, like when I boot the machine into the Mac OSX Server partition.

Additional info:

Here's a dump of `lspci`. Let me know what other information I can collect to help debug this.
Comment 1 Niels Haase 2009-06-24 18:52:40 EDT
Thanks for filling this bug. Can you please provide your lspci with -nn (lspci -nn). Without it, it's not useful, because the PCI ID's are missing. Second, please add the /var/log/messages after the start-up from the system. Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Nick Boldt 2009-06-28 00:59:28 EDT
Created attachment 349685 [details]
lspci -nn output
Comment 3 Nick Boldt 2009-06-28 01:00:20 EDT
Created attachment 349686 [details]
/var/log/messages after startup
Comment 4 Nick Boldt 2009-06-28 01:15:11 EDT
BTW, I tried installing e1000 driver (e1000e-0.5.18.3.tar.gz) for the Intel 82574L card from Intel site (http://ark.intel.com/Product.aspx?id=32209, http://downloadcenter.intel.com/filter_results.aspx?strTypes=all&ProductID=3023&OSFullName=Linux*&lang=eng&strOSs=39&submit=Go!), but that didn't help.
Comment 5 Niels Haase 2009-07-14 18:15:30 EDT
Can you please attach some more information?

'nm-tool' output

than run
'ifup eth0'
'dhclient eth0'

'nm-tool' output again

Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Nick Boldt 2009-08-21 17:06:26 EDT
Unfortunately, I blew away the partition w/ F11 on it because it wasn't working and I needed to move forward.
Comment 7 Dan Williams 2009-11-11 20:34:12 EST
I believe this is a case of the driver not having the IDs for 8086:10F6 at the time of install.  This is apparently fixed now with the 2.6.30.9-96.fc11 kernel since the e1000e has the device IDs for 8086:10F6.  So it's fixed now.

Note You need to log in before you can comment on or make changes to this bug.