Bug 507949 - Rawstudio crashes on start
Rawstudio crashes on start
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rawstudio (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Gianluca Sforna
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 15:55 EDT by Tuomas Haarala
Modified: 2009-07-12 17:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-12 17:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomas Haarala 2009-06-24 15:55:08 EDT
Description of problem:
Rawstudio crashes on start with following message:

(rawstudio:8277): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

Version-Release number of selected component (if applicable):
rawstudio-1.2-1.fc11.x86_64

How reproducible:
In similar manner as the problem manifests itself in the first place. Try starting rawstudio.

Steps to Reproduce:
1.Start rawstudio
2.
3.
  
Actual results:
Error message and crashed rawstudio;
"(rawstudio:8277): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed". 

Expected results:
Rawstudio running. No error messages.

Additional info:
Comment 1 Gianluca Sforna 2009-06-24 17:37:17 EDT
I am not sure the error message is really related to your problem, since I'm getting that one as well but in my PC the program loads without issues.

Are you able to get a backtrace of the crash?
Comment 2 Tuomas Haarala 2009-06-25 09:48:00 EDT
I get this when I run rawstudio with strace:

---clip---
...
open("/usr/share/fonts/dejavu/DejaVuSans.ttf", O_RDONLY) = 14
fcntl(14, F_SETFD, FD_CLOEXEC)          = 0
fstat(14, {st_mode=S_IFREG|0644, st_size=622020, ...}) = 0
mmap(NULL, 622020, PROT_READ, MAP_PRIVATE, 14, 0) = 0x7fd741468000
close(14)                               = 0
brk(0x1260000)                          = 0x1260000
brk(0x1286000)                          = 0x1286000
brk(0x12a9000)                          = 0x12a9000
brk(0x12cc000)                          = 0x12cc000
brk(0x12ee000)                          = 0x12ee000
brk(0x1310000)                          = 0x1310000
brk(0x1331000)                          = 0x1331000
poll([{fd=13, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=13, revents=POLLOUT}])
writev(13, [{"\22\0\n\0\3\0\0\4\202\1\0\0\202\1\0\0\10\0\0\0\20\0\0\0l\0\5\0\0\0\0\0\0"..., 324}, {NULL, 0}, {""..., 0}], 3) = 324
poll([{fd=13, events=POLLIN}], 1, -1)   = 1 ([{fd=13, revents=POLLIN}])
read(13, "\34\303\273\0\3\0\0\4\202\1\0\0\302\\;\3\0\214S\5\0\0\0\0\260\0R\5\0\0\0\0\34"..., 4096) = 160
read(13, 0x1164a44, 4096)               = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=13, revents=POLLOUT}])
writev(13, [{"&\0\2\0x\241\0\1"..., 8}, {NULL, 0}, {""..., 0}], 3) = 8
poll([{fd=13, events=POLLIN}], 1, -1)   = 1 ([{fd=13, revents=POLLIN}])
read(13, "\1\1\307\0\0\0\0\0\377\0\0\0\0\0\0\0G\0P\3\0\0\256\2\0 \0\0\1\0\0\0"..., 4096) = 32
read(13, 0x1164a44, 4096)               = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=13, revents=POLLOUT}])
...
---clip---

The desktop froze completely while doing this; I will try to use something else but gnome for another test.
Comment 3 Tuomas Haarala 2009-06-25 10:26:46 EDT
Another WM didn't change the behavior. Applying the latest updates however changed the situation, although in order to get the software fully functional, I had to remove the .rawstudio directory under the directory I had the batch of pictures in.

With the existing .rawstudio directory, the ui window flashed just before the software died - before the latest patches (looks like that kernel packages of version 2.6.29.5-191 made the difference) the window appeared, but died before UI was drawn.
Comment 4 Gianluca Sforna 2009-06-27 19:15:58 EDT
Please try to do the following:

1. install debuginfo packages with
yum --enablerepo=updates-debuginfo install rawstudio-debuginfo

2. install gdb
yum install gdb

3. run 
gdb rawstudio

4. type "run"

5. when it crashes type "bt"

6. attach the output here
Comment 5 Gianluca Sforna 2009-07-11 15:55:35 EDT
Are you still able to reproduce the issue or should i close this?
Comment 6 Tuomas Haarala 2009-07-12 16:33:11 EDT
The problem went away after kernel update; no reason to keep this open anymore.
Comment 7 Gianluca Sforna 2009-07-12 17:21:45 EDT
Ok. thanks

Note You need to log in before you can comment on or make changes to this bug.