Bug 50800 - choosing grub with update leaves unbootable system
choosing grub with update leaves unbootable system
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 51780 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 10:00 EDT by Gerald Henriksen
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 22:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Henriksen 2001-08-03 10:00:14 EDT
Description of Problem:

Upgraded my system from Seawolf to Roswell, chose to use grub from the
installers boot option menu.

When install finished and my system rebooted all I got was LI and the
system hung.

Tried to boot with the boot floppy that was created during the install
process and got the following:

Loading initrd.img...
Loading vmlinuz...
Boot failed: please change disks and press a key to continue

Booted into rescue mode from CD and was able to run lilo and restore my
system by using lilo instead of grub.
Comment 1 Sean Dilda 2001-08-04 11:45:10 EDT
Sounds like you used to have LILO on /dev/hda and installed grub on /dev/hda1,
so the old LILO still tried to run.

Also the floppy disk error just sounds like you have a bad floppy
Comment 2 Gerald Henriksen 2001-08-04 19:00:42 EDT
I have always installed lilo on the MBR, and I specified grub to be installed on
the MBR record also during the install process.

Just now I tried "grub-install /dev/hda" which I take to be the equivalent of
running lilo.  I got the following error message:

/dev/hdb5 does not have any corresponding BIOS drive

and grub thus failed to install.  I am guessing this same problem occurred when
anaconda tried to install grub, but the install process did not give me any
indication that their was a problem.

Just for info hda1 is a primary partition with Win98, hda2 is extended, hda5 is
Windows 2000, hdb1 is an extended partition, and hdb5 is my linux installation.
 This has been constant through several upgrades of Red Hat Linux.
Comment 3 Jeremy Katz 2001-08-06 17:00:18 EDT
Floppy disk sounds like a disk error... all too common =\

What does your /boot/grub/grub.conf look like?  (you should be able to boot with
a boot image and using rescue mode if nothing else).
Comment 4 Glen Foster 2001-08-06 18:43:20 EDT
We (Red Hat) should try to fix this for the next release.
Comment 5 Gerald Henriksen 2001-08-06 22:56:26 EDT
Note that grub apparently does not get installed at all as lilo still works.

/boot/grub/grub.conf as requested:

#boot=/dev/hda
default=0
timeout=30
splashimage=(hd1,4)/boot/grub/splash.xpm.gz
title Red Hat Linux (2.4.6-3.1)
	root (hd1,4)
	kernel /boot/vmlinuz-2.4.6-3.1 ro root=/dev/hdb5
	initrd /boot/initrd-2.4.6-3.1.img
title w2k
	rootnoverify (hd0,4)
	makeactive
	chainloader +1
title DOS
	rootnoverify (hd0,0)
	makeactive
	chainloader +1
Comment 6 Jeremy Katz 2001-08-07 17:09:07 EDT
If you add a line to /boot/grub/device.map of
(hd1)  /dev/hdb

and run `/sbin/grub-install /dev/hda`, that should fix the problem.

Fixed in CVS as well
Comment 7 Gerald Henriksen 2001-08-07 19:53:06 EDT
Problem is fixed.

Thanks.
Comment 8 Jeremy Katz 2001-08-14 21:48:40 EDT
*** Bug 51780 has been marked as a duplicate of this bug. ***
Comment 9 Robert L. Cochran Jr. 2001-08-14 22:33:49 EDT
Editing device.map and running '/sbin/grub-install /dev/hda' corrected my
problem too (bug 51780).
Comment 10 Daniel Lemye 2003-12-14 12:42:46 EST
After I updated my RH9 system with the latest security patches
(kernel), GRUB doesn't start anymore.
All what I get is "GRUB _" on the screen and the PC stops.

GRUB is on hdc2 (/boot). linux.bin in on hda1, launched by W2K boot
manager.
I have reinstalled GRUB many times (grub-install /dev/hdc2) with no
result.
Everything worked OK before update.
How could I switch to LILO ?
Dan

Note You need to log in before you can comment on or make changes to this bug.