Bug 508022 - [Software Update]When clicking "Software Update",it will give "An internal system error has occurred" window.
[Software Update]When clicking "Software Update",it will give "An internal sy...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 507952 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 03:49 EDT by Rita Wu
Modified: 2014-01-21 18:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 09:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rita Wu 2009-06-25 03:49:34 EDT
Description of problem:
When clicking "System->Administrator->Software Update",it will give "An internal system error has occurred" window.

Version-Release number of selected component (if applicable):
rawhide-11.9

How reproducible:
always

Steps to Reproduce:
1.Make sure it be updated to Jun.25.
2.Click "System->Administrator->Software Update"

  
Actual results:
After step 2,it will give "An internal system error has occurred" window.

Expected results:
After step 2, it can smoothly get update packages without any error.

Additional info:

Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2149, in get_distro_upgrades
    present_version = int(self.yumbase.conf.yumvar['releasever'])
ValueError: invalid literal for int() with base 10: '11.90'
Comment 1 Richard Hughes 2009-06-25 04:09:32 EDT
We've already fixed this upstream, but I'll update the package in rawhide today to fix this.
Comment 2 Rita Wu 2009-06-25 04:21:00 EDT
thanks for feedback quickly.
Comment 3 Matthias Clasen 2009-06-27 19:35:32 EDT
*** Bug 507952 has been marked as a duplicate of this bug. ***
Comment 4 Steven M. Parrish 2009-07-21 07:46:06 EDT
Richard what version was this fixed in?  Ok to close?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Richard Hughes 2009-07-21 09:36:06 EDT
Fixed in PACKAGEKIT_0_4_8 iirc.

Note You need to log in before you can comment on or make changes to this bug.