Bug 50804 - natsemi driver fails with smp kernel
Summary: natsemi driver fails with smp kernel
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-03 14:10 UTC by Gene Czarcinski
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 14:41:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up bootup (8.37 KB, text/plain)
2001-08-03 14:10 UTC, Gene Czarcinski
no flags Details
smp bootup (12.22 KB, text/plain)
2001-08-03 14:11 UTC, Gene Czarcinski
no flags Details
ls pci -v from up bootup (3.30 KB, text/plain)
2001-08-03 14:11 UTC, Gene Czarcinski
no flags Details

Description Gene Czarcinski 2001-08-03 14:10:06 UTC
Description of Problem:
Fresh custom install of Roswell on an Abit smp mobo.  The natsemi driver
fails when system booted up with smp kernel and the system is generally
hosed.  Works OK when booted with up kernel.

How Reproducible:
everytime

Steps to Reproduce:
1. Install Roswell on smp mobo.
2. boot
3.

Actual Results:
natsemi failure (see attached lspci -v and dmesg files)

Expected Results:
bootup works

Additional Information:

Comment 1 Gene Czarcinski 2001-08-03 14:10:45 UTC
Created attachment 26032 [details]
up bootup

Comment 2 Gene Czarcinski 2001-08-03 14:11:15 UTC
Created attachment 26033 [details]
smp bootup

Comment 3 Gene Czarcinski 2001-08-03 14:11:48 UTC
Created attachment 26034 [details]
ls pci -v from up bootup

Comment 4 Arjan van de Ven 2001-08-03 14:15:47 UTC
is the boot completely dead or can you still log in ?

Comment 5 Gene Czarcinski 2001-08-03 14:20:42 UTC
I can login but things are really hosed.  Doing "ifconfig" hangs.  The system is
suppose to come up with gdm for login ... gdm is started but doesn't work.

I got the dmesg-smp.txt after logging in.

Everything seems to depend on the network interface.

Comment 6 Gene Czarcinski 2001-08-03 14:21:39 UTC
I downloaded the 2.4.7-0.3 kernel and will give that a try next.

Comment 7 Arjan van de Ven 2001-08-03 14:22:41 UTC
if you can pull of doing a "dmesg | ksymoops" after the crash that would be
VERY helpful in finding the actual culprit.

Comment 8 Gene Czarcinski 2001-08-03 14:41:36 UTC
OK, 2.4.7-0.3 works -- the problem did not occur.

I suggest closed -> fixed in rawhide

Comment 9 Arjan van de Ven 2001-08-03 14:43:24 UTC
your wish is my command


Note You need to log in before you can comment on or make changes to this bug.