Bug 508071 - Networking: Recovery of networking settings on oVirt nodes is broken
Networking: Recovery of networking settings on oVirt nodes is broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Hypervisor
Classification: Retired
Component: vdsm (Show other bugs)
5.4-2.1
All Linux
high Severity high
: rc
: ---
Assigned To: Dan Kenigsberg
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 09:36 EDT by Daniel Paikov
Modified: 2016-04-18 02:52 EDT (History)
9 users (show)

See Also:
Fixed In Version: vdsm-4.4-32059, rhevh 5.5-2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 09:06:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2009-06-25 09:36:01 EDT
Recovery of networking settings on oVirt nodes (without running setSafeNetworkConfig) is broken. ifcfg-* files that are newly created by VDSM are discarded (as intended), but files that were pre-existing and were changed by VDSM's network settings are kept (NOT intended). After boot, this leaves a combination of both relevant and irrelevant network configuration files.
Comment 1 Daniel Paikov 2009-07-14 11:56:11 EDT
Checked on sp165.

Note You need to log in before you can comment on or make changes to this bug.