Bug 508141 - system.config.deplyAll is giving wrong error message when client doesn't have configfiles.deploy capability
system.config.deplyAll is giving wrong error message when client doesn't have...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Sayli Karmarkar
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2009-06-25 15:39 EDT by Sayli Karmarkar
Modified: 2009-09-10 15:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from catalina.out (32.85 KB, text/plain)
2009-06-25 15:39 EDT, Sayli Karmarkar
no flags Details

  None (edit)
Description Sayli Karmarkar 2009-06-25 15:39:46 EDT
Created attachment 349448 [details]
traceback from catalina.out

Description of problem:


Steps to Reproduce:
1. Register a client
2. Give provisioning capability
3. Create a configuration channel 
4. Create a file "/tmp/foo" in the config channel
5. execute api:

system.config.addChannels(key, systemIds, channelLabels, true);
where systemIds list contains id of the system registered and channelLabels list contains label of the config channel created. 
 This will succeed.

6. Now try executing:
system.config.deployAll(key, systemIds, earliestDate);
  
Actual results:
Warning null value received for obj.. Expected class type = java.lang.String
redstone.xmlrpc.XmlRpcFault: unhandled internal exception: null
tomcat traceback is attached. 

Expected results:
Error indicating: Client doesn't have configfiles.deploy capability. Please install rhncfg* packages from thn-tools channel.

Additional info:
Note that when client has rhncfg packages installed, deployAll works fine.
Comment 1 Brad Buckingham 2009-06-26 17:53:40 EDT
master git commit: 3bc4c571c889c85bd038a06f08bed865f3aeff0f
vader git commit: d4ca5991386fbdfa060d95758fdece11f1a6909a

Updated the logic to use text consistent with the UI.  Ex.

"The server <hostname> does not have the configfiles.deploy client capability. Please enable the capability before proceeding with the operation."

I did not specifically mention to install the rhncfg* packages, since the user can find out what steps are needed to become config capable by either the reference documentation or the UI at Configuration->ConfigurationChannels->channel->Systems(TargetSystems).  I didn't want to repeat this information in case the requirements later change for what is needed for a system to become config capable.
Comment 2 Sayli Karmarkar 2009-07-06 13:18:57 EDT
Error message seen as : "The server abc does not have the configfiles.deploy client capability. Please enable the capability before proceeding with the operation."

Moving to verified.
Comment 3 Milan Zazrivec 2009-08-25 09:45:02 EDT
Verified in stage with the same results as stated in previous comment.
RELEASE_PENDING
Comment 4 Brandon Perkins 2009-09-10 15:56:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.