Bug 508150 - setroubleshoot: SELinux is preventing dbus-daemon (system_dbusd_t) "write" tmpfs_t.
setroubleshoot: SELinux is preventing dbus-daemon (system_dbusd_t) "writ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:5fe2940f381...
:
: 508151 508152 508153 508154 508155 508157 508159 508160 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 16:21 EDT by Antonio A. Olivares
Modified: 2009-06-26 08:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 08:55:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio A. Olivares 2009-06-25 16:21:44 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing dbus-daemon (system_dbusd_t) "write" tmpfs_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by dbus-daemon. It is not expected that this
access is required by dbus-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:system_dbusd_t:SystemLow-
                              SystemHigh
Target Context                system_u:object_r:tmpfs_t:SystemLow
Target Objects                log [ sock_file ]
Source                        dbus-daemon
Source Path                   /bin/dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.2.12-1.fc11
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.19-1.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.24.rc0.git18.fc12.i586 #1 SMP Mon Jun 22
                              16:26:17 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Thu 25 Jun 2009 02:48:59 PM CDT
Last Seen                     Thu 25 Jun 2009 02:48:59 PM CDT
Local ID                      3734620e-dbfa-44ae-85bd-0343b4bbffc5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1245959339.799:87): avc:  denied  { write } for  pid=819 comm="dbus-daemon" name="log" dev=tmpfs ino=7121 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmpfs_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1245959339.799:87): arch=40000003 syscall=102 success=yes exit=0 a0=3 a1=b7fa79cc a2=497ff4 a3=0 items=0 ppid=1 pid=819 auid=4294967295 uid=81 gid=81 euid=81 suid=81 fsuid=81 egid=81 sgid=81 fsgid=81 tty=(none) ses=4294967295 comm="dbus-daemon" exe="/bin/dbus-daemon" subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= system_dbusd_t ==============
allow system_dbusd_t tmpfs_t:sock_file write;
Comment 1 Daniel Walsh 2009-06-26 08:55:16 EDT
You have a badly mislabeled system,  You must relabel.

touch /.autorelabel; reboot
Comment 2 Daniel Walsh 2009-06-26 08:56:05 EDT
*** Bug 508151 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2009-06-26 08:56:20 EDT
*** Bug 508152 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Walsh 2009-06-26 08:56:35 EDT
*** Bug 508153 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2009-06-26 08:57:05 EDT
*** Bug 508154 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Walsh 2009-06-26 08:57:19 EDT
*** Bug 508155 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Walsh 2009-06-26 08:57:31 EDT
*** Bug 508157 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Walsh 2009-06-26 08:57:49 EDT
*** Bug 508159 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Walsh 2009-06-26 08:58:01 EDT
*** Bug 508160 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.