Bug 508151 - setroubleshoot: SELinux is preventing kerneloops (kerneloops_t) "search" tmpfs_t.
setroubleshoot: SELinux is preventing kerneloops (kerneloops_t) "search"...
Status: CLOSED DUPLICATE of bug 508150
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:7dacd71b925...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 16:23 EDT by Antonio A. Olivares
Modified: 2009-06-26 08:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 08:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio A. Olivares 2009-06-25 16:23:02 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing kerneloops (kerneloops_t) "search" tmpfs_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by kerneloops. It is not expected that this
access is required by kerneloops and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:kerneloops_t:SystemLow-
                              SystemHigh
Target Context                system_u:object_r:tmpfs_t:SystemLow
Target Objects                / [ dir ]
Source                        kerneloops
Source Path                   /usr/sbin/kerneloops
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kerneloops-0.12-5.fc11
Target RPM Packages           filesystem-2.4.21-1.fc11
Policy RPM                    selinux-policy-3.6.19-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.24.rc0.git18.fc12.i586 #1 SMP Mon Jun 22
                              16:26:17 EDT 2009 i686 i686
Alert Count                   2
First Seen                    Thu 25 Jun 2009 03:17:25 PM CDT
Last Seen                     Thu 25 Jun 2009 03:17:25 PM CDT
Local ID                      c9423621-e35a-492c-bc59-01a9b2eb33e3
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1245961045.624:154): avc:  denied  { search } for  pid=6439 comm="kerneloops" name="/" dev=tmpfs ino=1012 scontext=system_u:system_r:kerneloops_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmpfs_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1245961045.624:154): avc:  denied  { write } for  pid=6439 comm="kerneloops" name="log" dev=tmpfs ino=7121 scontext=system_u:system_r:kerneloops_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmpfs_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1245961045.624:154): arch=40000003 syscall=102 success=yes exit=0 a0=3 a1=bff7101c a2=5ddff4 a3=ffffffc8 items=0 ppid=1 pid=6439 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kerneloops" exe="/usr/sbin/kerneloops" subj=system_u:system_r:kerneloops_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= kerneloops_t ==============
allow kerneloops_t tmpfs_t:dir search;
allow kerneloops_t tmpfs_t:sock_file write;
Comment 1 Daniel Walsh 2009-06-26 08:56:04 EDT

*** This bug has been marked as a duplicate of bug 508150 ***

Note You need to log in before you can comment on or make changes to this bug.