Bug 508182 - sm: symbol lookup error: /usr/lib64/jabberd/storage_db.so: undefined symbol: ser_string_set
sm: symbol lookup error: /usr/lib64/jabberd/storage_db.so: undefined symbol: ...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: jabberd (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 18:32 EDT by Jonathan Steffan
Modified: 2010-09-23 04:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 04:51:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Steffan 2009-06-25 18:32:35 EDT
Description of problem:
sm: symbol lookup error: /usr/lib64/jabberd/storage_db.so: undefined symbol: ser_string_set

Version-Release number of selected component (if applicable):
jabberd-2.2.5-1.el5

How reproducible:
Always

Steps to Reproduce:
1. yum install jabberd
2. Try starting it.
  
Actual results:
Failure starting.

Expected results:
Works.

Additional info:
This is fixed upstream. Please update.

http://www.mail-archive.com/jabberd2@lists.xiaoka.com/msg01179.html
https://bugs.launchpad.net/jabberd2/+bug/345947
Comment 1 Jonathan Steffan 2009-06-25 19:10:48 EDT
Please build this http://koji.fedoraproject.org/koji/buildinfo?buildID=107036 for the EL-5 branch and at least send it to epel-testing.
Comment 2 Adrian Reber 2009-06-26 05:55:10 EDT
I would first like to try if a recompile fixes it. Could you test it?
Comment 3 Jonathan Steffan 2009-07-04 14:52:48 EDT
I'll try a rebuild on Monday. I doubt it will fix the issue, however.
Comment 4 Adrian Reber 2009-07-04 17:01:36 EDT
A rebuild is available at:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1454553
Comment 5 Jonathan Steffan 2009-07-08 14:31:15 EDT
/usr/bin/sm: symbol lookup error: /usr/lib64/jabberd/storage_db.so: undefined symbol: ser_string_set

Please submit an update to epel-testing for the new build. Thanks.
Comment 6 Adrian Reber 2009-07-09 08:04:47 EDT
(In reply to comment #5)
> /usr/bin/sm: symbol lookup error: /usr/lib64/jabberd/storage_db.so: undefined
> symbol: ser_string_set

I am sorry. But I do not understand what this means. Does it mean that the new version still does not work?

> Please submit an update to epel-testing for the new build. Thanks.

I have tried jabberd-2.2.5-2.el5.x86_64 and it works without a problem.
Comment 7 Jonathan Steffan 2009-07-13 14:26:01 EDT
The rebuild does not work for us, no.
Comment 8 Christoph Sievers 2009-07-16 19:14:00 EDT
move sm to sm.orig and create a new sm that looks like this:

#!/bin/sh
LD_PRELOAD=/usr/lib64/jabberd/authreg_pipe.so
export LD_PRELOAD
exec /usr/bin/sm.orig


yes - it's ugly.

rgds
Christoph
Comment 9 Adrian Reber 2009-07-17 06:03:54 EDT
Ah, good point. Which backends are you (original reporter) using. I have done my tests with PAM and BDB. Maybe that is the reason I cannot reproduce it.
Comment 10 Devan Goodwin 2009-07-22 11:57:50 EDT
We've run into this problem with Fedora 11 i386, jabberd-2.2.7.1-2.fc11.i586.

Any chance we could get a 2.2.8 rebuild for F11? 

Our driver is "db".
Comment 11 Devan Goodwin 2009-07-22 12:03:56 EDT
Sorry scratch that, just saw that there is already a build in updates-testing for Fedora 11. Testing now and will add karma in koji if all is well.
Comment 12 Devan Goodwin 2009-07-22 12:42:21 EDT
Rebuild of 2.2.8 has been submitted for EL5 as well for those who are interested, should land in updates-testing soon.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1492414
Comment 13 Noa Resare 2009-09-23 04:18:20 EDT
with the jabberd-2.2.8-2.el5 available in EPEL for el5, using the db backend I can not reproduce this. I think it is safe to close this as FIXED.
Comment 14 Mark Chappell 2010-09-23 04:51:42 EDT
The new package has been in EPEL for over a year, and there has been no negative response to either Devan's or Noa's comments.  As such closing this one off as ERRATA.

Note You need to log in before you can comment on or make changes to this bug.