Bug 508231 - SAF Test lck: saLckResourceLockAsync/9.c
SAF Test lck: saLckResourceLockAsync/9.c
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openais (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ryan O'Hara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 05:42 EDT by Jan Friesse
Modified: 2009-06-29 15:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 15:22:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't assume a callback has been made until it is actually called. (5.22 KB, text/x-csrc)
2009-06-29 13:41 EDT, Ryan O'Hara
no flags Details

  None (edit)
Description Jan Friesse 2009-06-26 05:42:36 EDT
Description of problem:
Test in SUBJ doesn't work

Version-Release number of selected component (if applicable):
Trunk

How reproducible:
Run it

Steps to Reproduce:
1.
2.
3.

Actual results:
select error!

Expected results:
Test runs ok

Additional info:
It looks like saLckResourceUnlock doesn't cancel pending request lock
Comment 1 Ryan O'Hara 2009-06-29 13:40:04 EDT
This is a bug in the saftest code. The test code assumes that if select returns
a value > 0, a callback has been made. That isn't true, at least for OpenAIS. I
will attach a new version of the test case that doesn't depend on select to
determine is a callback has been made.
Comment 2 Ryan O'Hara 2009-06-29 13:41:01 EDT
Created attachment 349828 [details]
 Don't assume a callback has been made until it is actually called.

This code appears to fix the test case in question.
Comment 3 Ryan O'Hara 2009-06-29 15:22:35 EDT
Closing this as fixed upstream. OpenAIS lock service now has code to cancel/skip callbacks for resources that have been closed with pending callbacks. Fix for saftest code it attached above.

Note You need to log in before you can comment on or make changes to this bug.