Bug 508246 - KMS not working on Mobile Intel GMA 4500M (GL40)
KMS not working on Mobile Intel GMA 4500M (GL40)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 06:36 EDT by Michael Monreal
Modified: 2018-04-11 04:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: around xorg-x11-server 1.6.1.901-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 19:46:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (30.99 KB, text/plain)
2009-06-28 08:30 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-06-26 06:36:15 EDT
F11 Live does not display anything when booted on a brand new Lenovo G530 (Mobile Intel GMA 4500M (GL40) graphics) unless I boot it with "nomodeset". After installation, the system boots but it looks like the installer put "nomodeset" automatically.

I will try to provide any information you need.
Comment 1 Matěj Cepl 2009-06-27 09:51:18 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Michael Monreal 2009-06-27 10:13:56 EDT
There's no /etc/X11/xorg.conf anymore and /var/log/dmesg will obviously not help because I cannot provide the version of it when using KMS (as I get zero screen output).

I will try to get a meaningful Xorg.log as soon as I get access to the system again.
Comment 3 Michael Monreal 2009-06-27 10:23:37 EDT
Trying to reset to needinfo
Comment 4 Michael Monreal 2009-06-28 08:30:28 EDT
Created attachment 349701 [details]
Xorg.0.log

So I just instructed my GF to remove the nomodeset kernel option and boot. Surprisingly everything seems to work fine now. Maybe some post-release update already fixed the problem?

Anyway here's Xorg.0.log, please have a look and see if everything is fine. There are a few (EE)s inside but KMS, UXA and DRI2 seem to be working fine. Thanks!
Comment 5 Matěj Cepl 2009-06-30 19:46:16 EDT
Yeah, these are probably harmless:

(II) intel(0): Fixed memory allocation layout:
(II) intel(0): 0x00000000-0xffffffff: DRI memory manager (0 kB)
(II) intel(0): 0x00000000:            end of aperture
(II) intel(0): BO memory allocation layout:
(II) intel(0): 0x00000000:            start of memory manager
(II) intel(0): 0x02418000-0x027fffff: front buffer (4000 kB) X tiled
(II) intel(0): 0x02408000-0x02411fff: HW cursors (40 kB)
(II) intel(0): 0x00000000:            end of memory manager
(EE) intel(0): max_gtt_map_size: 55272kb.
Comment 6 Michael Monreal 2009-07-01 03:06:33 EDT
Thanks. Should I file the (EE)s separately (maybe on freedektop bugzilla) anyway?
Comment 7 Matěj Cepl 2009-07-02 17:13:29 EDT
(In reply to comment #6)
> Thanks. Should I file the (EE)s separately (maybe on freedektop bugzilla)
> anyway?  

We think that these (EE)s are harmless. Don't bother.

Thank you offer though, of course.

Note You need to log in before you can comment on or make changes to this bug.