Bug 508307 - glxgears cpu-scaling error
glxgears cpu-scaling error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 09:38 EDT by Arne Chr. Jorgensen
Modified: 2009-06-26 14:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 14:44:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arne Chr. Jorgensen 2009-06-26 09:38:10 EDT
Description of problem:

The calculation of fps seems to be wrong.

$ glxgears
1524 frames in 5.0 seconds = 304.720 FPS
2036 frames in 5.0 seconds = 407.042 FPS
1998 frames in 5.0 seconds = 399.522 FPS
2001 frames in 5.0 seconds = 400.032 FPS
1794 frames in 5.0 seconds = 358.654 FPS
1676 frames in 5.0 seconds = 334.839 FPS
172 frames in 5.0 seconds = 34.211 FPS
112 frames in 5.0 seconds = 22.390 FPS
112 frames in 5.0 seconds = 22.277 FPS
112 frames in 5.0 seconds = 22.255 FPS
112 frames in 5.1 seconds = 22.105 FPS
112 frames in 5.0 seconds = 22.273 FPS
111 frames in 5.0 seconds = 22.154 FPS

Scaling = Ondemand:

First 6 with CPU Scaling at 800MHz, then CPU shift to 2000MHz
 

Version-Release number of selected component (if applicable):
glx-utils-7.2-0.15.fc10(x86_64)

Kernel 2.6.27.24-170.2.68.fc10.x86_64
X.Org X Server 1.5.3
( no xorg.conf - radeon x1200 )

Smolt: pub_165cffbb-6c02-46d3-84e5-f81db90bcd53 

How reproducible:

always

Steps to Reproduce:
1. run it
2.
3.
  
Actual results:

- see output above

Expected results:

- increased fps as higher output

Additional info:

- in some web pages, the browser slow down to a "crawling" speed, almost halting. If more processing power is needed, it doesn't get it. 
Attempted to figure out if some feedback exist.

Where does it collect the info for calculation ?
Comment 1 Arne Chr. Jorgensen 2009-06-26 14:44:23 EDT
Updated 58 packages, new kernel, etc.

Tried the same thing, but cannot duplicate these numbers. Tried the old kernel,
with the same load. But nope, this does not make sense. Scaling *must* have gone down instead of up. And below 800.  



glxgears is not to blame. Not a bug.

Note You need to log in before you can comment on or make changes to this bug.